summaryrefslogtreecommitdiff
path: root/app-shells/fzf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 03:31:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 03:31:11 +0000
commit3a9a4f8b478ff62e3c752e20305edb2c7d91959f (patch)
treeaf2b80e575254ddcdc57ea6b2ae02607bb0a7824 /app-shells/fzf
parent7236d0a40beeff3f6f0fcede52d54dfb81880faa (diff)
gentoo auto-resync : 12:11:2022 - 03:31:11
Diffstat (limited to 'app-shells/fzf')
-rw-r--r--app-shells/fzf/Manifest3
-rw-r--r--app-shells/fzf/fzf-0.35.0.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index a648f17bc758..e87e1092b2d5 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -1,4 +1,7 @@
DIST fzf-0.34.0-deps.tar.xz 16800704 BLAKE2B b518f7bff1ea533af32efcb0e5307580aa921bbc20383bbdb6601c0b2dd50e66a57609c99adb9f71d1d388d08cae22521fea67797036d5dab34c83c45dd719fb SHA512 e5f6db58b43e6e3cb9b38f5fb13ab39b7caa18828516d13b0c4623f11a8553a905d076ef9685abfd9c7b602715d677dae9897359148b5d289b05ad056c60d321
DIST fzf-0.34.0.tar.gz 214641 BLAKE2B ccb7f57df4305cf07dc8e0ba7384c3a446ddce083727ad98719a327150d853782bf781b0179d02f3f10664ffce501ebab55ccd2d5f61a2e690fa41f1d0f479c1 SHA512 6e2bd9a7c30862c09f627c73504f2a52951476abbd9af64941445862cc9bf783699cc9ccf215e25c49bbb3f9656841581b5805af4658b681b590ca14b5697331
+DIST fzf-0.35.0-deps.tar.xz 16796112 BLAKE2B 61c22a914bb1eb8cb6da1daf4b25a19d98e7b0dcd1575b47b6da995ae0fb5e5bc47612b7abafe2917d12b4900a69e604ffff87bf31f811de449522fe800af8f4 SHA512 eed0a0c5a48c5dfee2b6c4d3320280d75f19c16841e3ad731371060da55885c3ddd8d0490dbfc53a68f095dcff02727e8d804494bfa8edf6da041ffcb197dc74
+DIST fzf-0.35.0.tar.gz 218715 BLAKE2B 7eb4a36e481738e56e031ec6e10c69b6499bd6fde204f8bc9474f80b9c6371ca66ebafd5733d4b5de3f2a1fed0c7f2b9b8bbb97681d6194a79f6c82088d6c28e SHA512 8dfdee14b6eced0f2fffc717d6f4e33b93531002754cfcc6b915169feb5f0b62060addf26eb43af028d3d62cdda3c2581a878305ed2fd89f0b27622b6d813cbb
EBUILD fzf-0.34.0.ebuild 1981 BLAKE2B fc7fb488bf7e901b470867b6443926438e57eead2d3c272dfbdaef308484e62e3f26c9944bc295b78a5a37cdc7d467cfd861d790143789d06028e65408837459 SHA512 177804d5b6c7048051cf1c737876229c4a333e1314e39daedd74874f62cde37516a3deb7389ae6ed9f84bfc18a5d953d894409af0dd4f4e7d65db30dd4435f0f
+EBUILD fzf-0.35.0.ebuild 1983 BLAKE2B b0dfbf8b8cf491e32f848cf765dea917cc8d24b77b8ef8a6722cb97095924c267c6cd25dd89914b9c571a724ec171f0c7a6e2ae7abe23efc652daaf6c5646010 SHA512 47196079455cd30f8199f2e77c1800a3eed44eddebba8286a3dfb1f604efed3c4dabe543c0d65934bf6f0cec5bfd04f4cb5fa9610edff09f858322fdf7444e58
MISC metadata.xml 469 BLAKE2B 3d6dcce756d040b715bbf17f33faea2c0ddd810857cb38289f59cab134a5b049d21db71c9c3844497643e1728ecd09a924a51ba273f736712543307f2b806d1a SHA512 21f3fef809b276da7f7ad33dbafefc2ebfa86b9ce9aa0dea664724c399a6743923a8a1825cffbd06d885181dc7b305d351e7ab77bd133abb98f601a84783f52f
diff --git a/app-shells/fzf/fzf-0.35.0.ebuild b/app-shells/fzf/fzf-0.35.0.ebuild
new file mode 100644
index 000000000000..dfb1e1fbede0
--- /dev/null
+++ b/app-shells/fzf/fzf-0.35.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=04d0b0223fd69984a07a641d0e228c0e9e534825
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug 795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}