summaryrefslogtreecommitdiff
path: root/app-shells/esh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-shells/esh
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-shells/esh')
-rw-r--r--app-shells/esh/Manifest4
-rw-r--r--app-shells/esh/esh-0.8.5-r2.ebuild31
-rw-r--r--app-shells/esh/metadata.xml2
3 files changed, 24 insertions, 13 deletions
diff --git a/app-shells/esh/Manifest b/app-shells/esh/Manifest
index d60e6c048d1f..0b1150112d8e 100644
--- a/app-shells/esh/Manifest
+++ b/app-shells/esh/Manifest
@@ -1,3 +1,3 @@
DIST esh-0.8.5.tar.gz 214040 BLAKE2B 8fbcfed21a9dc156f496cd650e1f7d4242f869d753b147070e51c357531353b9028de7cd405334e7171f805bf048d032310063e8fe2776de976557b080b2946e SHA512 2473cc2418f70533136305f47dfe59bee560206a8b58c080e2113297dd82483e867937bda1b015069a7220552b4d03346a3b71026a24a2795b0b499e355490a0
-EBUILD esh-0.8.5-r2.ebuild 1035 BLAKE2B 10f5eb2f9b69196a8d5c310eac1cb46ec47db65ef5ddbe0d8c36ca4ca443fa214f103c0c7221e6999b5c325d06b6245ae849dff77fa8b9bc32633fb48092d671 SHA512 f16ba2db0e0a5bb8ca0030d64f813c2d8ba84e8631db0db764d72c26b6a272d53822a7248adff2de47c234d6469455338fbb52007373ef0654477a072e39c60e
-MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
+EBUILD esh-0.8.5-r2.ebuild 1370 BLAKE2B c47baedc53b8f8bff6107e86a991982d2db0835e7c1c4642ae5eaaf4d6527fab07549d18edf1bfd8fd78c25ee2bbcd519d721473124c3db4e61cce2399e4dedc SHA512 1ee1334d77d6ecc635afb098a15e50480492da6fa26c7c72f4da842e0d542aaf4f583fc6413ebe9a0d19e018c47bb817ccc8b9f2737fd4b6c3d55477f102da2b
+MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/app-shells/esh/esh-0.8.5-r2.ebuild b/app-shells/esh/esh-0.8.5-r2.ebuild
index 052258caf92d..164a969d91f4 100644
--- a/app-shells/esh/esh-0.8.5-r2.ebuild
+++ b/app-shells/esh/esh-0.8.5-r2.ebuild
@@ -1,43 +1,51 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit flag-o-matic toolchain-funcs
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
HOMEPAGE="http://slon.ttk.ru/esh/"
SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug"
-DEPEND=">=sys-libs/readline-4.1"
+DEPEND=">=sys-libs/readline-4.1:="
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
+ default
+
+ # For some reason, this tarball has binary files in it for x86.
+ # Make clean so we can rebuild for our arch and optimization.
emake clean
sed -i \
-e 's|-g ||' \
-e 's|-DMEM_DEBUG ||' \
-e 's|^CFLAGS|&+|g' \
- -e 's|$(CC) |&$(CFLAGS) $(LDFLAGS) |g' \
+ -e 's|$(CC) |&$(CFLAGS) $(CPPFLAGS) $(INC) $(LDFLAGS) $(LIB) $(LIBS)|g' \
-e 's:-ltermcap::' \
+ -e "s:/usr/include/readline:${ESYSROOT}/usr/include/readline:" \
+ -e "s:LIB=-readline:$($(tc-getPKG_CONFIG) --libs readline):" \
Makefile || die
}
src_compile() {
- # For some reason, this tarball has binary files in it for x86.
- # Make clean so we can rebuild for our arch and optimization.
-
use debug && append-flags -DMEM_DEBUG
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags readline)"
+
emake \
CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} \$(INC)" \
+ CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
}
@@ -45,7 +53,10 @@ src_install() {
dobin esh
doinfo doc/esh.info
dodoc CHANGELOG CREDITS GC_README HEADER READLINE-HACKS TODO
- dohtml doc/*.html
+
+ docinto html
+ dodoc doc/*.html
+
docinto examples
dodoc examples/*
}
diff --git a/app-shells/esh/metadata.xml b/app-shells/esh/metadata.xml
index 6f49eba8f496..7a38bb900964 100644
--- a/app-shells/esh/metadata.xml
+++ b/app-shells/esh/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
</pkgmetadata>