summaryrefslogtreecommitdiff
path: root/app-shells/esh/esh-0.8.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/esh/esh-0.8.5-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/esh/esh-0.8.5-r2.ebuild')
-rw-r--r--app-shells/esh/esh-0.8.5-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-shells/esh/esh-0.8.5-r2.ebuild b/app-shells/esh/esh-0.8.5-r2.ebuild
new file mode 100644
index 000000000000..052258caf92d
--- /dev/null
+++ b/app-shells/esh/esh-0.8.5-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+HOMEPAGE="http://slon.ttk.ru/esh/"
+SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/readline-4.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ emake clean
+
+ sed -i \
+ -e 's|-g ||' \
+ -e 's|-DMEM_DEBUG ||' \
+ -e 's|^CFLAGS|&+|g' \
+ -e 's|$(CC) |&$(CFLAGS) $(LDFLAGS) |g' \
+ -e 's:-ltermcap::' \
+ Makefile || die
+}
+
+src_compile() {
+ # For some reason, this tarball has binary files in it for x86.
+ # Make clean so we can rebuild for our arch and optimization.
+
+ use debug && append-flags -DMEM_DEBUG
+
+ emake \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin esh
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER READLINE-HACKS TODO
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*
+}