summaryrefslogtreecommitdiff
path: root/app-shells/ctypes-sh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/ctypes-sh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/ctypes-sh')
-rw-r--r--app-shells/ctypes-sh/Manifest4
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.1.ebuild39
-rw-r--r--app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch18
-rw-r--r--app-shells/ctypes-sh/metadata.xml16
4 files changed, 77 insertions, 0 deletions
diff --git a/app-shells/ctypes-sh/Manifest b/app-shells/ctypes-sh/Manifest
new file mode 100644
index 000000000000..9288f202ac96
--- /dev/null
+++ b/app-shells/ctypes-sh/Manifest
@@ -0,0 +1,4 @@
+AUX ctypes-sh-1.1-makefile-fix.patch 893 BLAKE2B a665dbb0278fa98408da8e68c0a6fcd7c4558d1b99efc99bee5946f41a2ab864112fb5f7d9f44db5e182b0e190481da44e17a17fba5d954bb3f5b8e353936097 SHA512 4acbc4639058b628c09082aafeb7592b1f85e3db5ffe77d6db8807a6b4ae787c24685f305149ed9a76c5558c01e3d17fd6714aa1103c435364166b76df7baa26
+DIST ctypes-sh-1.1.tar.gz 437637 BLAKE2B d4279812d613a771ed405499dc623fce5faa00c22e75067857cea0a31e4a36a1531f7b27a1edff89075961bf5e8183bf0787a703cb36c1a8cbd7c03d8a18710f SHA512 0e136f5b9fc342875d02b1087daed60eed46f411765538f185d1da61430205113db72994ecdb125aded3eae114b3f487e7af398c1326334efdd197ee7de18a61
+EBUILD ctypes-sh-1.1.ebuild 740 BLAKE2B a4464f179f13d0763e24b4b13bc45679e7a1d63147e1b10240392779379982299b030166b382c63bcfc6ae1c9a1730df21897bd86aef4482df988c37eb6bee01 SHA512 7a698c3831b7c4f551e803c6d1d1fc7f28b293d316a92d2b5b738802bcdfd925bd31aef83cc8ad6f8e706e30ee90f164a553bee46cd4032a7d29f7f14d9e1382
+MISC metadata.xml 558 BLAKE2B 820b7e4f6e8c7fec2ba02cc164090f20464b78a137f53697532224a360c63952e219c77aebfad40f75673e2c8e82b08100358232290701d47fdf6b66426bfebb SHA512 514d59c04f3c419abcf7ab54a8860506bbcca810c2cafb911b4dcf468cb7b81f63e6f5c01b92c3bb5b2d10c2266bb7adf0ba264aba3bfe632aebcf7d1d3fb1a7
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
new file mode 100644
index 000000000000..e737d10f3e87
--- /dev/null
+++ b/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Foreign function interface for bash"
+HOMEPAGE="http://ctypes.sh/"
+SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/libffi
+ virtual/libelf
+ app-arch/xz-utils
+ app-arch/bzip2
+ app-shells/bash[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-fix.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ pushd test
+ PATH="${S}:${PATH}" \
+ LD_LIBRARY_PATH="${S}/src/.libs" \
+ make CC="$(tc-getCC)" || die "make check failed"
+ popd
+}
diff --git a/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch b/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
new file mode 100644
index 000000000000..9a2965a62bc5
--- /dev/null
+++ b/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
@@ -0,0 +1,18 @@
+commit 5e305160cc219fa63658148e3d258cb62dd043a3
+Author: rtlanceroad <rtlanceroad@gmail.com>
+Date: Wed Jul 27 14:49:21 2016 +0800
+
+ fix Makefile.am in src dir
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 8a9b682..71347bb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -11,6 +11,6 @@ ctypes_la_LIBADD += libstruct.la
+ noinst_LTLIBRARIES += libstruct.la
+ noinst_HEADERS += struct/dutil.h struct/dwarves.h struct/elf_symtab.h struct/gobuffer.h struct/hash.h struct/list.h struct/rbtree.h struct/strings.h
+ libstruct_la_SOURCES = struct/dutil.c struct/dwarves.c struct/gobuffer.c struct/struct.c struct/strings.c struct/dwarf_loader.c struct/dwarves_fprintf.c struct/elf_symtab.c struct/rbtree.c
+-libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE
++libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE $(FFI_CFLAGS)
+ libstruct_la_CPPFLAGS = -I../include -I../lib
+ endif
diff --git a/app-shells/ctypes-sh/metadata.xml b/app-shells/ctypes-sh/metadata.xml
new file mode 100644
index 000000000000..6086f8198355
--- /dev/null
+++ b/app-shells/ctypes-sh/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ctypes.sh is a bash plugin that provides a foreign function interface directly
+in your shell. In other words, it allows you to call routines in shared
+libraries from within bash.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">taviso/ctypes.sh</remote-id>
+ </upstream>
+</pkgmetadata>