summaryrefslogtreecommitdiff
path: root/app-shells/ctypes-sh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/ctypes-sh
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/ctypes-sh')
-rw-r--r--app-shells/ctypes-sh/Manifest5
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.1.ebuild39
-rw-r--r--app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch18
-rw-r--r--app-shells/ctypes-sh/metadata.xml16
4 files changed, 78 insertions, 0 deletions
diff --git a/app-shells/ctypes-sh/Manifest b/app-shells/ctypes-sh/Manifest
new file mode 100644
index 000000000000..b8b57e28aa9a
--- /dev/null
+++ b/app-shells/ctypes-sh/Manifest
@@ -0,0 +1,5 @@
+AUX ctypes-sh-1.1-makefile-fix.patch 893 SHA256 7a68e1209dc36859606cfa67a1a6a9e56c007a608948a19f3722aea949f85ac5 SHA512 4acbc4639058b628c09082aafeb7592b1f85e3db5ffe77d6db8807a6b4ae787c24685f305149ed9a76c5558c01e3d17fd6714aa1103c435364166b76df7baa26 WHIRLPOOL 378f71d910d35b2bc6215f4dcd453410e39f87a30ba7a36c7207933f23be4846f774998630eabf19483ce0884948290cac1a434995173ae301b73f0e01b5027e
+DIST ctypes-sh-1.1.tar.gz 437637 SHA256 f7c8276b556101c51838296560d152fdcd96b860254a38d216b92986f31f8297 SHA512 0e136f5b9fc342875d02b1087daed60eed46f411765538f185d1da61430205113db72994ecdb125aded3eae114b3f487e7af398c1326334efdd197ee7de18a61 WHIRLPOOL 7625df5a8d7e5284ee6012e59dc0ff1a2e11ccbec37edb5203d31529715916aefa609d0cd3c7964dfc225d0f476e37213f5936c17c74c2b76fb5ad0a9e02874c
+EBUILD ctypes-sh-1.1.ebuild 740 SHA256 5d3d677f3512551d94ef30a96e303858935069077ba9676a9193bad3b7ad5798 SHA512 7a698c3831b7c4f551e803c6d1d1fc7f28b293d316a92d2b5b738802bcdfd925bd31aef83cc8ad6f8e706e30ee90f164a553bee46cd4032a7d29f7f14d9e1382 WHIRLPOOL 8903fac6605e7d1b91f5431649ec3d25871c2e0a894aaeee2f10f0629846cda64e9493f5a8d3ca9525706cb50674ce4b9f9e1afb8f6777b6337daecfa12054bc
+MISC ChangeLog 554 SHA256 682dae55a57ff0c7669d004efbe28b3f4676a4c35124c79943290cf9ff8672e2 SHA512 c7e187b64c82d1e237a048f1612d4fea8bedc6089414d4ee7868e25606269d551115cf35259886cfa72e30a15fd420271c06a5f08bf501b47e7f709057fe588c WHIRLPOOL f37ad035427d8b1ea632fbbfb98982dac7057a59057cdedffa3df60980aedc8e6cdc2c562b0919b3cfa864b6487e040e24c7961b9de049eee894b0c289560597
+MISC metadata.xml 558 SHA256 8bdcbd15b8d2a3bc21a999be61aebc89e9f9db9c342e31aacccee3a4ac3b0afd SHA512 514d59c04f3c419abcf7ab54a8860506bbcca810c2cafb911b4dcf468cb7b81f63e6f5c01b92c3bb5b2d10c2266bb7adf0ba264aba3bfe632aebcf7d1d3fb1a7 WHIRLPOOL 55479f6a0af9a105ac3114145a46838edc52d05aee4fd4f422be8bbd48f1be1ad5254ba8143a70dac3d2015ba0b95770156cc3f7558bbe9e2fdc51e825cc4eb5
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
new file mode 100644
index 000000000000..e737d10f3e87
--- /dev/null
+++ b/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Foreign function interface for bash"
+HOMEPAGE="http://ctypes.sh/"
+SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/libffi
+ virtual/libelf
+ app-arch/xz-utils
+ app-arch/bzip2
+ app-shells/bash[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-fix.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ pushd test
+ PATH="${S}:${PATH}" \
+ LD_LIBRARY_PATH="${S}/src/.libs" \
+ make CC="$(tc-getCC)" || die "make check failed"
+ popd
+}
diff --git a/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch b/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
new file mode 100644
index 000000000000..9a2965a62bc5
--- /dev/null
+++ b/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
@@ -0,0 +1,18 @@
+commit 5e305160cc219fa63658148e3d258cb62dd043a3
+Author: rtlanceroad <rtlanceroad@gmail.com>
+Date: Wed Jul 27 14:49:21 2016 +0800
+
+ fix Makefile.am in src dir
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 8a9b682..71347bb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -11,6 +11,6 @@ ctypes_la_LIBADD += libstruct.la
+ noinst_LTLIBRARIES += libstruct.la
+ noinst_HEADERS += struct/dutil.h struct/dwarves.h struct/elf_symtab.h struct/gobuffer.h struct/hash.h struct/list.h struct/rbtree.h struct/strings.h
+ libstruct_la_SOURCES = struct/dutil.c struct/dwarves.c struct/gobuffer.c struct/struct.c struct/strings.c struct/dwarf_loader.c struct/dwarves_fprintf.c struct/elf_symtab.c struct/rbtree.c
+-libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE
++libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE $(FFI_CFLAGS)
+ libstruct_la_CPPFLAGS = -I../include -I../lib
+ endif
diff --git a/app-shells/ctypes-sh/metadata.xml b/app-shells/ctypes-sh/metadata.xml
new file mode 100644
index 000000000000..6086f8198355
--- /dev/null
+++ b/app-shells/ctypes-sh/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ctypes.sh is a bash plugin that provides a foreign function interface directly
+in your shell. In other words, it allows you to call routines in shared
+libraries from within bash.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">taviso/ctypes.sh</remote-id>
+ </upstream>
+</pkgmetadata>