summaryrefslogtreecommitdiff
path: root/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild')
-rw-r--r--app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild b/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
new file mode 100644
index 000000000000..665558ef2924
--- /dev/null
+++ b/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
+
+S="${WORKDIR}/${MY_P}"
+
+# Unfortunately, not all tests pass.
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # We don't install this, so don't bother building it. #468044
+ sed -i 's:texi2html:true:' doc/Makefile.in || die
+}
+
+src_configure() {
+ # This path matches the bash sources. If we ever change bash,
+ # we'll probably have to change this to match. #591994
+ econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}