summaryrefslogtreecommitdiff
path: root/app-shells/bash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
commit0bff53119f08d677db6c1a991bd30741682a8a08 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /app-shells/bash
parent6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (diff)
Revert "gentoo resync : 02.06.2018"
This reverts commit 6c14fa2586d9e9c4427b5f727dc6c8ab77587cec.
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/Manifest1
-rw-r--r--app-shells/bash/bash-4.3_p39_pre0.ebuild136
2 files changed, 137 insertions, 0 deletions
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index 832aaec73930..60a9b466d949 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -364,6 +364,7 @@ EBUILD bash-3.2_p57.ebuild 4534 BLAKE2B e1a52abe31b056271064462cbfd95b00d469292a
EBUILD bash-4.0_p44.ebuild 4408 BLAKE2B 13955f4505ba051f1880ce023f2f12e9531433473463c717099f66b1cfb103381d9ffdd6f6948a2e05875445f4e2a43b09f0053066829e71d53bdaf55f37fa89 SHA512 c50783ef42181a245900a7df3578a75b47af48b0e48d5478d6739be48c2487b6d8de866b0e7f26cae18e67aac6f4e8aa6b54da77c22f61ce43a8e79cca296257
EBUILD bash-4.1_p17.ebuild 4142 BLAKE2B 5d8f2b031eb26211ff1f778629cfb8d9255b357e3217346511b3b70e6fc55b6e697c4991e3f505420eb295da5d973b4faceb7edbfca03b91c278bf01b7464602 SHA512 e5f5e135c543aa5dfac81936b1b25e9894aa62918c01214f48abc6a4d1d1251fda8be3566164d324b8644822745f634dd7e4265805d276be822fc190fe2e8146
EBUILD bash-4.2_p53.ebuild 4344 BLAKE2B 5565a97a0aa9465fd8eef2de0b78434c04096d84c988cdbb663af4b529e1207cc68d0030fa4d88e4028fa7bef08847df170a274ccba316213cceb7401163ed00 SHA512 d3cae3853f6c3b735dd9083b9f7d16bd96aac1ba29ba49e8d5e62140ebdb97f4c9d36e3bc36fcd96f32685236fe6bb80d53015b9dbb20a829968aa535a949a3f
+EBUILD bash-4.3_p39_pre0.ebuild 3581 BLAKE2B 51c88610e9a35420efa938d7bcedc09005a7c86cf5fe45a671607a89e517442f8316667f7883ef87bc5671ed1898097bbc4fd3d5e2d4baa515601cddf8abc8b3 SHA512 f41cf7c82dc1316f61e132a2b29a2e4ac5b7a20f3856b69d51d39a18723c7e4713fec3654331d8bf4425f84d8d43408834d4e63934f7369232d87ce12156d2a2
EBUILD bash-4.3_p48-r1.ebuild 7248 BLAKE2B 3a8e835dd559ddb5495ce716ee869e279276502f8f0128732e59ab14e89f3860cf65dd68e5d1125ecdbbcaf3fc6d128f24a78a0fcf7e98b1bdfbd73757c420f6 SHA512 b60301a8e2d14f4f7ecc85d12e17d62f0b5ee8b1b8753a4dd17dc2b818eb424521f34cd48bd5335b6108392ac56aa62cd12e8d65070ae8bb5ca6b090000ad13a
EBUILD bash-4.4_p12-r1.ebuild 7222 BLAKE2B dbea2f6145b913878f4ddbb549e1735f71f59f58bec7378164029c767243b695e85486782c24f752473754115d2be77a8416496b5c3552cff97e218b3acaff4b SHA512 7399a4bb123edce35bd9e8614cf0ac738906c47d7679d50e01d1712c1b8324d7cc2c680a7ff57ea1dcbe6d2e988aa01f318d9d8a8fb5f0f50428bc4ac9d2dc7c
EBUILD bash-4.4_p12.ebuild 7161 BLAKE2B a91c473aed8cc403559edb09eecb315ea1cc72d408411190c64f9ccf76b6c841ab4a41d317534bc9cecd13f85a881afe9880b1e83e1ccb28ea82c2e63faa160a SHA512 fbbe64caa19d373008b9bbced1d2b3578e4d3515f5e4e8b05e43ffa167470544af3dd11076876a7dbee299e9948c8a956565cd0e6f38dcdf42bbd5b56fbd1c13
diff --git a/app-shells/bash/bash-4.3_p39_pre0.ebuild b/app-shells/bash/bash-4.3_p39_pre0.ebuild
new file mode 100644
index 000000000000..d16084790da5
--- /dev/null
+++ b/app-shells/bash/bash-4.3_p39_pre0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Old ebuild to help with people doing live upgrades w/old portage versions.
+# We use the bundled versions of readline & termcap to avoid external deps
+# (which in turn would require those packages to keep an old EAPI version).
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-4.3-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_PV=${MY_PV/_/-}
+MY_P=${PN}-${MY_PV}
+[[ ${PV} != *_p* ]] && PLEVEL=0
+patches() {
+ local opt=$1 plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
+ [[ ${plevel} -eq 0 ]] && return 1
+ eval set -- {1..${plevel}}
+ set -- $(printf "${pn}${pv/\.}-%03d " "$@")
+ if [[ ${opt} == -s ]] ; then
+ echo "${@/#/${DISTDIR}/}"
+ else
+ local u
+ for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${pn} ; do
+ printf "${u}/${pn}-${pv}-patches/%s " "$@"
+ done
+ fi
+}
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://tiswww.case.edu/php/chet/bash/bashtop.html"
+SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
+
+LICENSE="GPL-3"
+SLOT="0"
+#KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+# Note: We export this because portage wants it enabled.
+IUSE="+readline"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+}
+
+src_prepare() {
+ # Include official patches
+ [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
+
+ # Avoid regenerating docs after patches #407985
+ sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
+ touch -r . doc/*
+
+ epatch "${FILESDIR}"/${PN}-4.3-compat-lvl.patch
+ epatch "${FILESDIR}"/${PN}-4.3-append-process-segfault.patch
+ epatch "${FILESDIR}"/${PN}-4.3-mapfile-improper-array-name-validation.patch
+ epatch "${FILESDIR}"/${PN}-4.3-arrayfunc.patch
+}
+
+src_configure() {
+ local myconf=()
+
+ # For descriptions of these, see config-top.h
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
+ append-cppflags \
+ -DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
+ -DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
+ -DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
+ -DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
+ -DNON_INTERACTIVE_LOGIN_SHELLS \
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
+
+ # Force internal copy of termcap to be used (to avoid ncurses dep).
+ export bash_cv_termcap_lib=gnutermcap
+
+ # Disable the plugins logic by hand since bash doesn't
+ # provide a way of doing it.
+ export ac_cv_func_dl{close,open,sym}=no \
+ ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+ sed -i \
+ -e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
+ configure || die
+
+ tc-export AR #444070
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --htmldir='$(docdir)/html' \
+ --disable-nls \
+ --without-curses \
+ --without-afs \
+ --disable-net-redirections \
+ --disable-profiling \
+ --disable-mem-scramble \
+ --without-bash-malloc \
+ --enable-readline \
+ --enable-history \
+ --enable-bang-history \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ local f
+
+ emake DESTDIR="${D}" install || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/ || die
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/bash_logout
+ doins "${FILESDIR}"/bashrc
+ keepdir /etc/bash/bashrc.d
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ local sed_args=(
+ -e "s:#${USERLAND}#@::"
+ -e '/#@/d'
+ )
+ sed -i \
+ "${sed_args[@]}" \
+ "${D}"/etc/skel/.bashrc \
+ "${D}"/etc/bash/bashrc || die
+}