summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /app-shells/bash/bash-9999.ebuild
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'app-shells/bash/bash-9999.ebuild')
-rw-r--r--app-shells/bash/bash-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 5fecc6b0353c..b0207e51036e 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -246,6 +246,8 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
+ tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+
# Rebuild Bash using the profiling data we just generated.
emake clean
emake CFLAGS="${CFLAGS} -fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo"