summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-5.2_beta.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-shells/bash/bash-5.2_beta.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-shells/bash/bash-5.2_beta.ebuild')
-rw-r--r--app-shells/bash/bash-5.2_beta.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/app-shells/bash/bash-5.2_beta.ebuild b/app-shells/bash/bash-5.2_beta.ebuild
index 9c0db54a6049..851264513714 100644
--- a/app-shells/bash/bash-5.2_beta.ebuild
+++ b/app-shells/bash/bash-5.2_beta.ebuild
@@ -5,8 +5,6 @@ EAPI=7
# TODO on release:
# - check READLINE_VER, obviously
-# - remove autotools/eautoreconf from readline ebuild
-# - tidy up is_release check in this ebuild for using system readline
# (presumably there weren't always readline releases for bash RCs etc)
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/chetramey.asc
@@ -20,8 +18,8 @@ MY_PV="${MY_PV/_/-}"
MY_P="${PN}-${MY_PV}"
is_release() {
case ${PV} in
- *_alpha*|*_beta*|*_rc*) return 1 ;;
- *) return 0 ;;
+ 9999|*_alpha*|*_beta*|*_rc*) return 1 ;;
+ *) return 0 ;;
esac
}
[[ ${PV} != *_p* ]] && PLEVEL=0
@@ -42,11 +40,16 @@ patches() {
}
# The version of readline this bash normally ships with.
-READLINE_VER="8.2_beta"
+# Note: right now, we don't use the system copy of readline for bash for non-releases.
+READLINE_VER="8.2"
DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="https://tiswww.case.edu/php/chet/bash/bashtop.html"
-if is_release ; then
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/bash.git"
+ EGIT_BRANCH=devel
+ inherit git-r3
+elif is_release ; then
SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
SRC_URI+=" verify-sig? ( mirror://gnu/bash/${MY_P}.tar.gz.sig )"
else
@@ -56,7 +59,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-if [[ ${PV} != *_alpha* && ${PV} != *_beta* && ${PV} != *_rc* ]] ; then
+if is_release ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline"
@@ -95,9 +98,12 @@ pkg_setup() {
}
src_unpack() {
- verify-sig_src_unpack
-
- unpack ${MY_P}.tar.gz
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ verify-sig_src_unpack
+ unpack ${MY_P}.tar.gz
+ fi
}
src_prepare() {
@@ -167,8 +173,7 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- # TODO: Clean this up before 5.2 release
- if [[ ${PV} == *_alpha* || ${PV} == *_beta* || ${PV} == *_rc* ]] || is_release ; then
+ if is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi