summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-4.2_p53.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-shells/bash/bash-4.2_p53.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-shells/bash/bash-4.2_p53.ebuild')
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 30c860c3ff58..44b74704aa85 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -42,21 +42,22 @@ LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-4.2-execute-job-control.patch #383237
+ "${FILESDIR}"/${PN}-4.2-execute-job-control.patch # bug #383237
"${FILESDIR}"/${PN}-4.2-parallel-build.patch
"${FILESDIR}"/${PN}-4.2-no-readline.patch
- "${FILESDIR}"/${PN}-4.2-read-retry.patch #447810
+ "${FILESDIR}"/${PN}-4.2-read-retry.patch # bug #447810
"${FILESDIR}"/${PN}-4.2-speed-up-read-N.patch
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -86,7 +87,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -120,12 +127,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}