summaryrefslogtreecommitdiff
path: root/app-shells/bash-completion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 19:35:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 19:35:31 +0000
commited43421253416ff58a637be8932ac1d7b7b232de (patch)
tree3cf7b0046bd17c3d59b7621101a7fd606fc2662b /app-shells/bash-completion
parent2d644a12e4e4d5061eeff8d068db29d562eba35b (diff)
gentoo auto-resync : 03:03:2023 - 19:35:31
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/Manifest4
-rw-r--r--app-shells/bash-completion/bash-completion-2.11.ebuild59
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild56
3 files changed, 74 insertions, 45 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 5665472482b1..ff7ab854ebfa 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,5 +1,5 @@
DIST bash-completion-2.11.tar.xz 311004 BLAKE2B 98e3ab6669bd70b49b238a597f1bc1309dc7ddd51c5b17c5e054f9161115d75d26e85d547471bc087e070d10554448b790a6dfb557abc413b70079ecc94acce3 SHA512 41585f730b5114d397831ba36d10d05643c6a6179e746ddc49aa1cbef61ea5525fd2f09b2e474adee14e647f99df8d5983ee48e29a59d8a30e1daf7fb1837e06
DIST bashcomp-2.0.3.tar.gz 3539 BLAKE2B 75304d144792cc7f6ad5455a05a65c33c646d6f7384d020a06a1fcf012cd51625a3dd0750ad539253453b1eede196c340286a1e81737f0835b5091609ba01295 SHA512 b2bd185ccbd4456939ccc731cc1983fcec2b9564a9920642a753fadd5d897fdb96b925ac1524657629d621d45b37d99076c8ae72511a827e96ff6c388d720008
-EBUILD bash-completion-2.11.ebuild 4065 BLAKE2B bbb7904ed0e07ae9847495eb952517d772a96d97e096072f5028ffb69ba5c0ea711c6de751e48a0e7fc138df7c5894113c6cbced5c2975c7bbf8e2d4269298eb SHA512 383e5b09cbb06ad8fc4c0b56eff2738a5734f3f9e7838014092a9654d81220c1118c918d1c58d9fd32ce5be2c3f47a80824adb8aa64cbf069aecddde54a8e962
-EBUILD bash-completion-9999.ebuild 4000 BLAKE2B d059bc9e4ff7808f2937a80973b1cf1bf2389fb95e81b40fee33e1b2d8f33eeb7c6eb3f6a99ccd61c19add3e9c91e520cc7bae3b8eaa70832718595cfa95b907 SHA512 d84174e939c20052dad59377332291de214214931fa36d12395381ae53c547901fa34bf9446f732cdeae5fe88d9b9b412900b2b6475e3eb70bf74e94a38ea7b5
+EBUILD bash-completion-2.11.ebuild 4157 BLAKE2B 367659e95f14c1af3dc22f0ae4528b7143d2b60f9c8be0c0c9c3381a9fda4d8fb51ecb283c90532a5778f067fc9b92be6175642cd2f85ee380071b2d1a67fbbb SHA512 925b41b9e0d31056da5583ea99d52ab1665cc888998e0295979bfcc95dc9d61b08de5ccc8201a2d4436ecf2e41666de2b67bc8bd3419c927777830e16d04d712
+EBUILD bash-completion-9999.ebuild 4056 BLAKE2B 902b3b26a311642b0db7215eb01dc89563c0952f33df20b68bb3d41494657b7f8026631456341c74322a1faf24413958be730c5d25b8121e9b59398a3173451d SHA512 5471542f0bbc5a029e4a1042d56c58778e6b5c96b1eeb0b8c169aec0adeed54b30e4a92455ed109a0565b5ba733801eb24196fb28865a7b51bc96525818ff2aa
MISC metadata.xml 1433 BLAKE2B 09156ab369dfe03c5817a71b97c30cf768222c8f464441a0f04de8b2f0c6b9591545f2f0a62547f87241e7d787b565986fbe5903bfde7d1f1c2f6752d7dd12db SHA512 e18dee528d2f67f83044e9f6d218280c394f1508c9ce59d4dbec72302ac20125edd021924359ffaa52208a234a2246b3a710cd24b80d387701d37505092d7b27
diff --git a/app-shells/bash-completion/bash-completion-2.11.ebuild b/app-shells/bash-completion/bash-completion-2.11.ebuild
index c7bcbfdfe2e6..6353cab23964 100644
--- a/app-shells/bash-completion/bash-completion-2.11.ebuild
+++ b/app-shells/bash-completion/bash-completion-2.11.ebuild
@@ -1,17 +1,21 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
BASHCOMP_P=bashcomp-2.0.3
-PYTHON_COMPAT=( python3_{9..10} )
-inherit bash-completion-r1 python-any-r1 user-info
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-any-r1
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
SRC_URI="
https://github.com/scop/bash-completion/releases/download/${PV}/${P}.tar.xz
- eselect? ( https://github.com/mgorny/bashcomp2/releases/download/v${BASHCOMP_P#*-}/${BASHCOMP_P}.tar.gz )"
+ eselect? (
+ https://github.com/projg2/bashcomp2/releases/download/v${BASHCOMP_P#*-}/${BASHCOMP_P}.tar.gz
+ )
+"
LICENSE="GPL-2+"
SLOT="0"
@@ -20,18 +24,23 @@ IUSE="+eselect test"
RESTRICT="!test? ( test )"
# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1:0
+RDEPEND="
+ >=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
- !!net-fs/mc"
-DEPEND="
+ !!net-fs/mc
+"
+BDEPEND="
test? (
${RDEPEND}
$(python_gen_any_dep '
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
')
- )"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+ )
+"
+PDEPEND="
+ >=app-shells/gentoo-bashcomp-20140911
+"
strip_completions() {
# Remove unwanted completions.
@@ -67,8 +76,8 @@ strip_completions() {
}
python_check_deps() {
- has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
- has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
pkg_setup() {
@@ -76,23 +85,31 @@ pkg_setup() {
}
src_prepare() {
- use eselect &&
+ if use eselect; then
eapply "${WORKDIR}/${BASHCOMP_P}/bash-completion-blacklist-support.patch"
-
- # redhat-specific, we strip these completions
- rm test/t/test_if{down,up}.py || die
- # not available for icedtea
- rm test/t/test_javaws.py || die
+ fi
eapply_user
}
src_test() {
+ local EPYTEST_DESELECT=(
+ # redhat-specific, we strip these completions
+ test/t/test_if{down,up}.py
+ # not available for icedtea
+ test/t/test_javaws.py
+ # TODO
+ test/t/test_xmlwf.py::TestXmlwf::test_2
+ )
+
# portage's HOME override breaks tests
- local myhome=$(unset HOME; echo ~)
- local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
- addpredict "${myhome}"
- emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
+ local -x HOME=$(unset HOME; echo ~)
+ addpredict "${HOME}"
+ # used in pytest tests
+ local -x NETWORK=none
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ emake -C completions check
+ epytest
}
src_install() {
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index ee41ba30bbde..8d39bca2b242 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
-inherit autotools git-r3 python-any-r1 user-info
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools git-r3 python-any-r1
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
@@ -17,18 +18,23 @@ IUSE="+eselect test"
RESTRICT="!test? ( test )"
# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1:0
+RDEPEND="
+ >=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
- !!net-fs/mc"
-DEPEND="
+ !!net-fs/mc
+"
+BDEPEND="
test? (
${RDEPEND}
$(python_gen_any_dep '
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
')
- )"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+ )
+"
+PDEPEND="
+ >=app-shells/gentoo-bashcomp-20140911
+"
strip_completions() {
# Remove unwanted completions.
@@ -64,8 +70,8 @@ strip_completions() {
}
python_check_deps() {
- has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
- has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
pkg_setup() {
@@ -73,10 +79,10 @@ pkg_setup() {
}
src_unpack() {
- use eselect && git-r3_fetch https://github.com/mgorny/bashcomp2
+ use eselect && git-r3_fetch https://github.com/projg2/bashcomp2
git-r3_fetch
- use eselect && git-r3_checkout https://github.com/mgorny/bashcomp2 \
+ use eselect && git-r3_checkout https://github.com/projg2/bashcomp2 \
"${WORKDIR}"/bashcomp2
git-r3_checkout
}
@@ -88,21 +94,26 @@ src_prepare() {
eapply "${WORKDIR}"/bashcomp2/bash-completion-blacklist-support.patch
fi
- # redhat-specific, we strip these completions
- rm test/t/test_if{down,up}.py || die
- # not available for icedtea
- rm test/t/test_javaws.py || die
-
eapply_user
eautoreconf
}
src_test() {
+ local EPYTEST_DESELECT=(
+ # redhat-specific, we strip these completions
+ test/t/test_if{down,up}.py
+ # not available for icedtea
+ test/t/test_javaws.py
+ )
+
# portage's HOME override breaks tests
- local myhome=$(unset HOME; echo ~)
- local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
- addpredict "${myhome}"
- emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
+ local -x HOME=$(unset HOME; echo ~)
+ addpredict "${HOME}"
+ # used in pytest tests
+ local -x NETWORK=none
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ emake -C completions check
+ epytest
}
src_install() {
@@ -116,9 +127,10 @@ src_install() {
dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
# install the eselect module
- use eselect &&
+ if use eselect; then
emake -C "${WORKDIR}"/bashcomp2 DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" install
+ fi
}
pkg_postinst() {