summaryrefslogtreecommitdiff
path: root/app-shells/autojump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/autojump
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/Manifest7
-rw-r--r--app-shells/autojump/autojump-22.2.4-r4.ebuild83
-rw-r--r--app-shells/autojump/autojump-22.5.1.ebuild76
-rw-r--r--app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch22
-rw-r--r--app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch67
-rw-r--r--app-shells/autojump/metadata.xml15
6 files changed, 270 insertions, 0 deletions
diff --git a/app-shells/autojump/Manifest b/app-shells/autojump/Manifest
new file mode 100644
index 000000000000..cf26d77de79e
--- /dev/null
+++ b/app-shells/autojump/Manifest
@@ -0,0 +1,7 @@
+AUX autojump-22.2.4-fix-__aj_error-typo.patch 755 BLAKE2B 022a80e29cf8a03e358c011f1bb5f8e3625a53d90371ac05b4d8abae94dfdd76a98976b75278b8d3477df2903706eb6a5a4fe16925d5101cb9e11d5549709b95 SHA512 8661ceae090ed70498f5ed34f447c80d3cf359eca304e16c122a992538af8fb5e046c26d739ccf9bcfd7ccd5706735aebc494f95ebcb2d3c300b126dc0e38136
+AUX autojump-22.2.4-fix-autojump.fish-bugs.patch 2100 BLAKE2B 5aef4c4363b0a34238e91a012b19a8a6041a2e72d9d071753ce2c14db2062e93cd7cae93862d3a78ed1645993b41f5c6a31d777dc204675983bd76578400c7dc SHA512 a0a2fb0a06e43f4b1321d0b785ffa3273ba5d35e103f4ac687d6f08502835dd0cd5135a871640e05b535fce31c11f2e9908728c1e6f62ffe1e313ed9c75b7670
+DIST autojump-22.2.4.tar.gz 52724 BLAKE2B 42d5db90d4a29c63f5cd79437ca005f9f6382a607ab9284244fd6bbcf539509c5043df71ab305a5e8420ec225f8d651411d327833762737e0a5ad828ac021d2b SHA512 bdfca07bb57b3a2733a2085af14f23c3e980b1b00db1c90247c2341ac73f60f171bdde29dd9917aac0808d0b8f2902d48096c990e09281745a71755f5abc921c
+DIST autojump-22.5.1.tar.gz 54721 BLAKE2B ea3a852dddc13ece5ff177be0b3f384e5dcb19795d31d22edae90dba19fe3e78a4b78f48f08c338521d89d57af6251d5690c62eab445229812adb154286b0d5c SHA512 ed1bb28b62d14a481d5c8ee8ebbfc286d21ca54c961904f81ac123c784e17810217dfe1689bdd4b50fd7a9d72509c0cb13583a9817074f6afe26dc3144f64243
+EBUILD autojump-22.2.4-r4.ebuild 2116 BLAKE2B e354d40e8f165ec2ddfc546ed7a82afe561cdd0ecfe0eff9c2dd8f6ff2f6c4faa5dfe8b884d97f4197399e3110b0635a19b8c1f141b3eda6083ed44b199df58c SHA512 c2a3239a7ba6ef8ec144ed271824e9b839b709ca2533d68d12499af0f3281cafb1b34ff58d8f85e9cee366f4674e46f5bfaf66be08b6038d121def8c06f0cb6a
+EBUILD autojump-22.5.1.ebuild 1951 BLAKE2B 1eacd3ff45cfbeeb923b5deb5b1faa23caadf4d8ce769fa91ae63c22bf3e2e76791a39f9e1b909119e97285b26369a50dcb0ab104befb8561345230baf4d51bf SHA512 d41fc0f7bac8ec6966b01bd78733680468fcb3f5cc9161c78c42ecde6bcd3223f9a2a6b81aebcf48f8b1b630f48e625c03f7a86fe80bebb97a7e3568113fb427
+MISC metadata.xml 503 BLAKE2B c2ead3167237d69f09ac2e5ebf8920b6ec2cf8d3800daf5aa8ce474067aeba88087914c39346414d707c3440c18592cae6d2c1e42718991bf41428a65136d733 SHA512 5173d3dcf39215a8ce67a9eb37127f4945d1420180a48f952d417d73e83bbd03fe1cdcbbb193b69f5eec3cfb994c12f8a92b4e6e22844b30753024dc0919a10d
diff --git a/app-shells/autojump/autojump-22.2.4-r4.ebuild b/app-shells/autojump/autojump-22.2.4-r4.ebuild
new file mode 100644
index 000000000000..37fdc8405ed0
--- /dev/null
+++ b/app-shells/autojump/autojump-22.2.4-r4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 python-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="ipython test"
+REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
+
+# Not all tests pass. Need investigation.
+RESTRICT="test"
+RDEPEND="ipython? ( ${PYTHON_DEPS} )"
+DEPEND="test? ( dev-python/flake8 dev-python/tox )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-autojump.fish-bugs.patch"
+ "${FILESDIR}/${P}-fix-__aj_error-typo.patch"
+)
+
+src_prepare() {
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -e "s:/usr/local/share:/usr/share:" \
+ -i bin/autojump.sh || die
+
+ # autojump_argparse is only there for Python 2.6 compatibility
+ sed -e "s:autojump_argparse:argparse:" \
+ -i bin/autojump || die
+
+ # upstream fixes to the autojump.fish script; the first patch is needed for
+ # the second patch to apply
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/"${PN}"
+ python_replicate_script "${ED}"/usr/bin/"${PN}"
+
+ insinto /etc/profile.d
+ doins bin/"${PN}".sh
+
+ insinto /usr/share/"${PN}"/
+ doins bin/"${PN}.bash"
+ doins bin/"${PN}.zsh"
+ doins bin/"${PN}.fish"
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+
+ python_foreach_impl python_domodule bin/autojump_data.py bin/autojump_utils.py
+ if use ipython; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+ fi
+
+ doman docs/"${PN}.1"
+ dodoc README.md
+}
+
+pkg_postinst() {
+ if use ipython; then
+ elog 'This tool provides "j" for ipython, please add'
+ elog '"import autojump_ipython" to your ipy_user_conf.py.'
+ elog
+ fi
+
+ elog 'If you use app-shells/fish, add the following code to your'
+ elog 'config.fish to get autojump support:'
+ elog 'if test -f /usr/share/autojump/autojump.fish'
+ elog ' source /usr/share/autojump/autojump.fish'
+ elog 'end'
+}
diff --git a/app-shells/autojump/autojump-22.5.1.ebuild b/app-shells/autojump/autojump-22.5.1.ebuild
new file mode 100644
index 000000000000..a5865f7617f0
--- /dev/null
+++ b/app-shells/autojump/autojump-22.5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 python-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/wting/autojump"
+SRC_URI="https://github.com/wting/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="ipython test"
+REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
+
+# Not all tests pass. Need investigation.
+RESTRICT="test"
+RDEPEND="ipython? ( ${PYTHON_DEPS} )"
+DEPEND="test? ( dev-python/flake8 dev-python/tox )"
+
+src_prepare() {
+ eapply_user
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -e "s:/usr/local/share:/usr/share:" \
+ -i bin/autojump.sh || die
+
+ # autojump_argparse is only there for Python 2.6 compatibility
+ sed -e "s:autojump_argparse:argparse:" \
+ -i bin/autojump || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/"${PN}"
+ python_replicate_script "${ED}"/usr/bin/"${PN}"
+
+ insinto /etc/profile.d
+ doins bin/"${PN}".sh
+
+ insinto /usr/share/"${PN}"/
+ doins bin/"${PN}.bash"
+ doins bin/"${PN}.zsh"
+ doins bin/"${PN}.fish"
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+
+ python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py \
+ bin/autojump_match.py bin/autojump_utils.py
+ if use ipython; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+ fi
+
+ doman docs/"${PN}.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use ipython; then
+ elog 'This tool provides "j" for ipython, please add'
+ elog '"import autojump_ipython" to your ipy_user_conf.py.'
+ elog
+ fi
+
+ elog 'If you use app-shells/fish, add the following code to your'
+ elog 'config.fish to get autojump support:'
+ elog 'if test -f /usr/share/autojump/autojump.fish'
+ elog ' source /usr/share/autojump/autojump.fish'
+ elog 'end'
+}
diff --git a/app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch b/app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch
new file mode 100644
index 000000000000..6a9ac3c83c8e
--- /dev/null
+++ b/app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch
@@ -0,0 +1,22 @@
+From d188d7e6757a4d0cad619b6d5ab729fdc59b1593 Mon Sep 17 00:00:00 2001
+From: Scott Olson <scott@scott-olson.org>
+Date: Mon, 6 Jul 2015 23:12:35 -0400
+Subject: [PATCH] Fix typo (__aj_error -> __aj_err).
+
+---
+ bin/autojump.fish | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/autojump.fish b/bin/autojump.fish
+index ead7ea1..b16ef01 100644
+--- a/bin/autojump.fish
++++ b/bin/autojump.fish
+@@ -91,7 +91,7 @@ function jo
+ case cygwin
+ cygstart "" (cygpath -w -a (pwd))
+ case '*'
+- __aj_error "Unknown operating system: \"$OSTYPE\""
++ __aj_err "Unknown operating system: \"$OSTYPE\""
+ end
+ else
+ __aj_err "autojump: directory '"$argv"' not found"
diff --git a/app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch b/app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch
new file mode 100644
index 000000000000..6048ca989376
--- /dev/null
+++ b/app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch
@@ -0,0 +1,67 @@
+From f09d23e30d3159db18872a3e8f8f579ed9e77231 Mon Sep 17 00:00:00 2001
+From: David Frascone <David.Frascone@dishdigital.com>
+Date: Tue, 9 Jun 2015 14:32:38 -0600
+Subject: [PATCH] Fixed some bugs in fish script
+
+OSTYPE was not being set correctly. It is in bash, not sh.
+ Since the value is unlikely to change, I read it once and
+ stored it globally
+Test logic was backward in jo function, causing error to always
+ be printed, unless you did NOT specify a directory name.
+---
+ bin/autojump.fish | 20 ++++++++++++--------
+ 1 file changed, 12 insertions(+), 8 deletions(-)
+
+diff --git a/bin/autojump.fish b/bin/autojump.fish
+index 2cf5001..19cb27e 100644
+--- a/bin/autojump.fish
++++ b/bin/autojump.fish
+@@ -5,6 +5,11 @@ if test -d ~/.autojump
+ set -x PATH ~/.autojump/bin $PATH
+ end
+
++# Set ostype, if not set
++if not set -q OSTYPE
++ set -gx OSTYPE (bash -c 'echo ${OSTYPE}')
++end
++
+
+ # enable tab completion
+ complete -x -c j -a '(autojump --complete (commandline -t))'
+@@ -34,7 +39,7 @@ end
+ # misc helper functions
+ function __aj_err
+ # TODO(ting|#247): set error file location
+- echo $argv 1>&2; false
++ echo -e $argv 1>&2; false
+ end
+
+ # default autojump command
+@@ -73,11 +78,7 @@ end
+ function jo
+ set -l output (autojump $argv)
+ if test -d "$output"
+- __aj_err "autojump: directory '"$argv"' not found"
+- __aj_err "\n$output\n"
+- __aj_err "Try `autojump --help` for more information."
+- else
+- switch (sh -c 'echo ${OSTYPE}')
++ switch $OSTYPE
+ case 'linux*'
+ xdg-open (autojump $argv)
+ case 'darwin*'
+@@ -85,9 +86,12 @@ function jo
+ case cygwin
+ cygstart "" (cygpath -w -a (pwd))
+ case '*'
+- __aj_error "Unknown operating system: '"$OSTYPE"'"
++ __aj_error "Unknown operating system: \"$OSTYPE\""
+ end
+- echo end
++ else
++ __aj_err "autojump: directory '"$argv"' not found"
++ __aj_err "\n$output\n"
++ __aj_err "Try `autojump --help` for more information."
+ end
+ end
+
diff --git a/app-shells/autojump/metadata.xml b/app-shells/autojump/metadata.xml
new file mode 100644
index 000000000000..b8e575f5b4d9
--- /dev/null
+++ b/app-shells/autojump/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/joelthelion/autojump/issues</bugs-to>
+ <remote-id type="github">joelthelion/autojump</remote-id>
+ </upstream>
+ <use>
+ <flag name="ipython">Add support for <pkg>dev-python/ipython</pkg></flag>
+ </use>
+</pkgmetadata>