summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-19 06:30:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-19 06:30:51 +0000
commitf8bb2d659372d0add11c589dcb006d0b7f8822ae (patch)
tree5d64f4f593db363260360200660abcd8ff00d1c6 /app-shells
parentf57e008aa126ccdca95f7424e4d24a1a83a49682 (diff)
gentoo auto-resync : 19:12:2024 - 06:30:51HEADmaster
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin10637 -> 10639 bytes
-rw-r--r--app-shells/fzf/Manifest3
-rw-r--r--app-shells/fzf/fzf-0.57.0.ebuild72
3 files changed, 75 insertions, 0 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index 8e5c7aa05bd3..b3ed31375cd7 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index d25e6659c325..669192f3bb11 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -1,4 +1,7 @@
DIST fzf-0.56.3-deps.tar.xz 5884504 BLAKE2B b5ffa8dd62e81d4db0266b1c66ebcb3938dc5a7702aced44f516327e2f94c7b381ac50e43dad012934c7adb397aa1b6c73b75fac91723838cc39c5c8d0076018 SHA512 ac15caa887d5d01fde7de5ed9dfc3c6c8b91ef583577aafe6ab93486732201b46625467ce1fc076a5b2ec5f6f71aa63d96c649564fe4ee672e950cf03d904c28
DIST fzf-0.56.3.tar.gz 300405 BLAKE2B d4139fd5fc95d710f18f5415f98e512c58812d5e5849481b47898b618dd33f33cfa532a9b767a787f565337f7ca8ea383f6bf10100ef90a78bbba9ad77e68fa3 SHA512 7144036bf3d027272bb1f961bb6a2721a7a85b16955b45f67798e16ac9f7891a04ed3b343b71c3426358e9e92abe1faba10b679caf8f99ca1905c6b312e6c9b7
+DIST fzf-0.57.0-deps.tar.xz 5890984 BLAKE2B 7d1bfbcbc01f99e77d601cec1080a45d8565320f4998f1ff4691ae3afbdbd7733c5861282e6d2167bb68d02ff06331913dad53ecdce6cd2ca6ced9ba11518279 SHA512 2c46a268cea450ff224e8251354443b1f7aa7f5a939e976c2a92fa3218444504205de3a72064820df2ee25b0d4de30e7f8877d4fa004e850d82eb13f2453e9ff
+DIST fzf-0.57.0.tar.gz 303081 BLAKE2B ab478c15e9229105b73275155a54bcf3dfcfcc9704414fd84511932572156c8695982c9aee2b5f609a9ec4b82ff895a96c11bd30c5d1f1345273a7272a2d71bc SHA512 1e5a76e647bb1ab784582b1e8069df908d844e564ab1c2c7cf9d389326a97ffc3c8c102050c40656ef60039f70284ceef78b3c739d7c32ff84b7493aac71f7d2
EBUILD fzf-0.56.3.ebuild 1974 BLAKE2B efe8be83b0e904661b1737785f363893c938271cf3e60ddd66ef0dc850ef64a3206333d03db0dd041464634b1b14d8df17b9892aee5607ae5affd1572d99618d SHA512 9b032bb342e6bb069de8c4214d65534d15de4557b6f3a7cace048ede1f1be586ccb16a62d2dc97ce9bd96686f64b0076e230c9749bd94790d1c8ef897cf86d75
+EBUILD fzf-0.57.0.ebuild 1977 BLAKE2B 443a553020643076c316730c7e556e4371566653af8a4a75d794cce690e33a52f967b6608b11bb64eedaa35663275633b2493d3b13e60c46906f4b9b501da118 SHA512 3176d21bee6dd6f60f67b768657ce7dfc3d34e39c02faa3f646a57ddcc1f741281a1f4baba46b3b27327fb04468d3eadfd73364dcc273329847f003896d4ea26
MISC metadata.xml 245 BLAKE2B 09740ccf075e53d0d7f0a31addb391335518828e2c889718899491764305e6fef814d1ff7f1228d4b3c2b3b18470873d3c71338154a833d3a7d13280c393a879 SHA512 4de0cd558c25997c8473254016ddf6371da40c183b7ff0d7ad873135e12f52f8de12c40dc6ee03aa1fc2e44898fa050c9730e76f7960d908a5fa6645a66a7679
diff --git a/app-shells/fzf/fzf-0.57.0.ebuild b/app-shells/fzf/fzf-0.57.0.ebuild
new file mode 100644
index 000000000000..959a06f96205
--- /dev/null
+++ b/app-shells/fzf/fzf-0.57.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=0476a65fca287a1cd17ae3cbdfd8155eb0fb40ad
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}