summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
commitd285f0ab4ab38d4ea1cd0757a465db5f06764e06 (patch)
tree1fec673dcd26669902404a2986868912c5b41860 /app-portage
parenta6764d56b1c85c8272783500983011c143c72d80 (diff)
gentoo auto-resync : 06:12:2024 - 02:07:38
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9757 -> 9758 bytes
-rw-r--r--app-portage/pkg-testing-tools/Manifest4
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild32
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild4
4 files changed, 37 insertions, 3 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index 4e9dd628d684..8ec9678d214d 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/pkg-testing-tools/Manifest b/app-portage/pkg-testing-tools/Manifest
index d4d4ab5146a7..c4bdc6ef5398 100644
--- a/app-portage/pkg-testing-tools/Manifest
+++ b/app-portage/pkg-testing-tools/Manifest
@@ -1,4 +1,6 @@
DIST pkg-testing-tools-0.2.5.gh.tar.gz 12870 BLAKE2B 5ed2c55522212c00b7cc4919b38f94e32c5fbd63e9386b6b45ca1245ba738678e17d2e6d460e736a2e10da2b546ad7b054e5a2a339c45000d628f59d05a49a46 SHA512 0f1379222134e87068581fe33cdb875e2d6804b663c8203e437a3bf685a1def44512067c04ddd585902ef63c5585ee8ac7c8466f49df77c09e1f7af3bb6744d3
+DIST pkg-testing-tools-0.2.6.gh.tar.gz 13068 BLAKE2B b0a01fab453ac2f5c73ed3bed0c324df4b74314ead3c38a06f26fc5a3c277fc4b2be1870e5552703e023882633ea164d6dd9b36bc338197cd519ca64e966985d SHA512 ec83644ffed01af86dbed056a0c5e78a737ee52046f8cc1b303af73f42deb9851d43521809305972117689e0545812b67c6375164add45122ed36a648ff816df
EBUILD pkg-testing-tools-0.2.5.ebuild 704 BLAKE2B ed686cc0b5c27eacd0e696df5e69be1901d01508d9c287bc1ab8ecfb2bed58c09278c3cb1a2f7a25de30a916bc02077c0a6da253ea1f8a3913024dc250c29d22 SHA512 8a1cf93caf191819bd903bbb301f9bd13e8dea054f3964b3ceabec3abb181d16b36e60e3344a06e28703c202df99b427727b482e1f9eeae0eaa8cca2e9d81728
-EBUILD pkg-testing-tools-9999.ebuild 706 BLAKE2B 4c11f4442905e442197dc6881dff678b052252e55b93f0bea15074e411b5fcd60130d61a62c661401c29301edc63cf51cc49b1157be3b51a4b4b85c400ab6e03 SHA512 dbbbc5d23ccad8e3a87c51d808682d9ff1fdd659c14914259d673e2d17c69bc8c3759db086801726394d7c5cb3a64aa941b413bfe42a5814f4b171f1be33e141
+EBUILD pkg-testing-tools-0.2.6.ebuild 704 BLAKE2B c856ff75c6a50102a8118d84ac98d9a63e4fb2193f2d3f33a81e706acb37d60d11acef19ab0caeb113cd4e965bae8985da9560d99574b778ab087bafb3cdb623 SHA512 e04bb804a261d68961d5c1657625bb08091e64ee10b29d634fc25b9f559bc8e6a1ee567a059c0757eaffe3626c1259f1f2416eb56b4d2aaaef52ab57b225bd79
+EBUILD pkg-testing-tools-9999.ebuild 704 BLAKE2B c856ff75c6a50102a8118d84ac98d9a63e4fb2193f2d3f33a81e706acb37d60d11acef19ab0caeb113cd4e965bae8985da9560d99574b778ab087bafb3cdb623 SHA512 e04bb804a261d68961d5c1657625bb08091e64ee10b29d634fc25b9f559bc8e6a1ee567a059c0757eaffe3626c1259f1f2416eb56b4d2aaaef52ab57b225bd79
MISC metadata.xml 511 BLAKE2B 28c5a606539ab4e39b0113ce58ac6cb8331f54ea459b0d38025873cf14f7eb84a1b170b2c8f352f989270d621620af611fb567c0ee5e400e098c4214fd981b95 SHA512 d0cafe6f9fe869007bf701796d1bceee66fefb6b6e3cfb413ab2a651709d625e117bd5c8e5d23d5647af1f6de95870da6be7344655e7fe15d48d831dba316cea
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild
new file mode 100644
index 000000000000..16b7250b0083
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
+
+REPO=APN-Pucky
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/${REPO}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
index c8cd079994a1..16b7250b0083 100644
--- a/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -20,7 +20,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
else
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
- SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ SRC_URI="https://github.com/${REPO}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
fi
IUSE="test"