summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
commit8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (patch)
treedd40a3ea9cdcc06c8c63bd2ee71c2c2c0ea11549 /app-portage
parent7825305c5ddf11fffe24fa30453c4e8468f64305 (diff)
gentoo auto-resync : 08:03:2024 - 19:07:58
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9935 -> 9937 bytes
-rw-r--r--app-portage/pfl/Manifest2
-rw-r--r--app-portage/pfl/pfl-3.5.ebuild49
3 files changed, 51 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index 0b98609d5303..d8d90f6691c0 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index 827a4888e279..2a22f9426843 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1,3 +1,5 @@
DIST pfl-3.4.tar.gz 18651 BLAKE2B 09793883a1ed6f70da2f01fb81cfafa407ed43584a826f2cd8fde6d75b544ed803a220fc517e649774100da32e64d01fad8ff0dcbaff9068f57cdf7bd4414169 SHA512 c21b43f234a778d74e05cd45b7ccb48b131d6998e632d044a4bccc2f772099d02d1c5e7ab75fc6f9deb14e2f1ed1f31bac51e917e628065b4a36d73b8d77336f
+DIST pfl-3.5.tar.gz 20882 BLAKE2B 695867e9f612d49aa0d54830733403fa3351f8545b530243ba00cb72e73e258a2a3da5d6a3a9f4674d542ea8bf4994c56056f21aa385c5dfc3bb2f233cf47a39 SHA512 4c058cf3530c584cad03f11e19d7e102429d4150958cd14275e884c0ea7e5c205ecf0604858ccd65bbc60d0df8e385a2496909b049b24e8cb52a3a685349c38e
EBUILD pfl-3.4.ebuild 1258 BLAKE2B e92c308c63933f364d9da729728645804ca61e147d014f2471859e56d960a30cfc88f075b0d47333c62387cfcb32824a2e1b1609ff4ff00a01ec030ea4041610 SHA512 2e91c79d985712ed7b53c34b296dbc3842c4c176a4e04b4914346d2b7e47850e68a122e2534a6beea26babdd408c22e526e53a5c92a731d5e0ecc0cbab3f5b9d
+EBUILD pfl-3.5.ebuild 1265 BLAKE2B 9b424f7e3ec3eadb8120a8046ee09de8a0fe6357e7f2dbeb33523fb544d1e39999a6f32d9f19b6f1db365313340fa452abb959c7df8e7397a928961f837ac045 SHA512 44de1e63856a22d6ccae2eedc248961eb60062eecb4714054f68857360695f04c5b490f6fb26d48ddab4f9c62ea47322b650f58b76b09aa5c1901dc326bba2e0
MISC metadata.xml 584 BLAKE2B fd0efa0091e062c54bafbae6ba72101c43335b44071fa6bec9fd05583e4cd5b65372eda758bce4a4ab61581811c65f8f4a7515e1d63a66b57f9d9ef60d40f4ba SHA512 c194c1d03bd40333d00263e40534b7c980d54184a934f6199a6d2e008f35bef9f18883523f8678cf7e8472ac4dcbd5a817c587e4f80664407c44a4d24fe82497
diff --git a/app-portage/pfl/pfl-3.5.ebuild b/app-portage/pfl/pfl-3.5.ebuild
new file mode 100644
index 000000000000..08f27aa7c608
--- /dev/null
+++ b/app-portage/pfl/pfl-3.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
+SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+ network-cron? ( sys-apps/util-linux[caps] )
+"
+
+S="${WORKDIR}/client-${PV}"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ systemd_dounit systemd/pfl.{service,timer}
+
+ keepdir /var/lib/${PN}
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}