summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 17:40:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 17:40:28 +0000
commit5cf235d5f7f308ba0183f7fa588514966b692114 (patch)
tree196baba60d7e0a81069198200d56fe6364bb238b /app-portage
parente4be1c42deab59fa5baee33fa9b1c48e5c4c6dc7 (diff)
gentoo auto-resync : 27:02:2024 - 17:40:28
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9754 -> 9930 bytes
-rw-r--r--app-portage/command-not-found/Manifest3
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.2.ebuild40
-rw-r--r--app-portage/command-not-found/metadata.xml12
4 files changed, 55 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index d2c886881059..a17afe61d4d8 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
new file mode 100644
index 000000000000..7182da1dde02
--- /dev/null
+++ b/app-portage/command-not-found/Manifest
@@ -0,0 +1,3 @@
+DIST command-not-found-0.0.2.tar.gz 9039 BLAKE2B 9781ce588e3e90868dc35745d5f4b24586dd365a0bd2a37a15d973e942ebbd0710675268fe3875be621be51ee7e4b9800865de3d99d58927588d2f05cfe6b789 SHA512 b2b81b754d96364e58d8f71d7024c2c4bc635aff7bd17df4bbc14791f9d7cbd266b2d4ab369ccaaed7b4aca5bb41622c3ce5d7a81795221c5dae3bed001447e4
+EBUILD command-not-found-0.0.2.ebuild 1087 BLAKE2B 0312f19a5cd0a491e99f222690b9617c4460e24fbb0247e69d7cc8b24cc27a4d0167eebcfcefaa4fc71bc53f652cb2f38f2762eae4bc0c8f2bf6729740beb223 SHA512 f90140768d687495607fd6396a7fb39b98461a34002a059c4b341a43e2fe961dcfd27241c8ac4447ab8ad437e7013c54a5b582d1411b7c79eae576c552b40367
+MISC metadata.xml 388 BLAKE2B 68d4cf665b154331bff48ea9c1cc0b68eea52cd82788f8cbe5e12907206036fb98ae8248738c34c6c221041055129e17aace5d47bd482b4cf27f36d09743b8c8 SHA512 08b5b851ffa5774aef0c2f0e6e7d3fb180492e898ab3197ce15e79a77ab04f7aa12e9213cb369998e48173af4a447ca94e9c5a61324771ad7d9ca2d1a4f5de80
diff --git a/app-portage/command-not-found/command-not-found-0.0.2.ebuild b/app-portage/command-not-found/command-not-found-0.0.2.ebuild
new file mode 100644
index 000000000000..b0007e526a58
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "command-not-found is automatically setup with bash, to use it with zsh add"
+ elog " \"source /etc/bash/bashrc.d/command-not-found.sh\""
+ elog "anywhere in your /etc/zsh/zshrc or ~/.zshrc"
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}
diff --git a/app-portage/command-not-found/metadata.xml b/app-portage/command-not-found/metadata.xml
new file mode 100644
index 000000000000..87d84e421471
--- /dev/null
+++ b/app-portage/command-not-found/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AndrewAmmerlaan/command-not-found-gentoo</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>