summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
commit34f71cb8541190212fa250ceb3dafb53f383beea (patch)
tree75894a0bd212c9a6464b37d48f418fcb5cc3ff82 /app-portage
parent18bf6672cbde96e8498ce4bfc974af9bb4f95613 (diff)
gentoo auto-resync : 04:04:2024 - 20:14:38
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9906 -> 9905 bytes
-rw-r--r--app-portage/command-not-found/Manifest2
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.5.ebuild40
3 files changed, 42 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index d03321d3d85e..378d5d82ff04 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
index 2de5e68f7a98..ff487f360c92 100644
--- a/app-portage/command-not-found/Manifest
+++ b/app-portage/command-not-found/Manifest
@@ -1,3 +1,5 @@
DIST command-not-found-0.0.4.tar.gz 10028 BLAKE2B b1740a01400ed0084ad22414a586926132d6c9e6994de50812cf885d947c4bd95e65d715bcbc8b13f173464a7896ff6b8ee95782ab8a18d5884aa338bffa28ae SHA512 1c0ed9d17f7cfa18b8d1a8fd914716f6e44dd514f79e92ea8d33e4b0ee8d2556ee23b8853d286993fe72a1bdf23fc656f276fe8264bf78fef83f045169efe7c2
+DIST command-not-found-0.0.5.tar.gz 10045 BLAKE2B 5225fe4512516518172b1c7d25563488f26b359e0698a3352ebf2143dd7983fee2c44050e2b4abf72377780875436861855f0891bc10d429fba9bba695808bf3 SHA512 9125e168d64b7474f83d1bc8ed7f54ef332190d0d7325c281f1a041d47b23ce18170dff2fa3342468941cba7b0197821790ef5d1e9b8c1ee1f5a6ba1383b1005
EBUILD command-not-found-0.0.4.ebuild 1065 BLAKE2B 70760ceab17a507d1f4a9b46c5a1a80a520b6fa22a41aed819d3d9f873a760accad95c0bff047ae4233bba2bf21e93a23e98c22e3feef6afd6dd885e0f0492d7 SHA512 6f7134ad4cbaf894fd8e11b74008e268d9a8d545efa10d491d881f87b8f809d65a5dc22692006e059a7ad75c16b03e4ddcbae59c0e26730c4eaeb84029f3a3fb
+EBUILD command-not-found-0.0.5.ebuild 1065 BLAKE2B 70760ceab17a507d1f4a9b46c5a1a80a520b6fa22a41aed819d3d9f873a760accad95c0bff047ae4233bba2bf21e93a23e98c22e3feef6afd6dd885e0f0492d7 SHA512 6f7134ad4cbaf894fd8e11b74008e268d9a8d545efa10d491d881f87b8f809d65a5dc22692006e059a7ad75c16b03e4ddcbae59c0e26730c4eaeb84029f3a3fb
MISC metadata.xml 388 BLAKE2B 68d4cf665b154331bff48ea9c1cc0b68eea52cd82788f8cbe5e12907206036fb98ae8248738c34c6c221041055129e17aace5d47bd482b4cf27f36d09743b8c8 SHA512 08b5b851ffa5774aef0c2f0e6e7d3fb180492e898ab3197ce15e79a77ab04f7aa12e9213cb369998e48173af4a447ca94e9c5a61324771ad7d9ca2d1a4f5de80
diff --git a/app-portage/command-not-found/command-not-found-0.0.5.ebuild b/app-portage/command-not-found/command-not-found-0.0.5.ebuild
new file mode 100644
index 000000000000..1859d6690bfe
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} is automatically setup for app-shells/bash, see"
+ elog " /usr/share/doc/${PF}/README.md"
+ elog "for instructions on how to set it up for various other shells."
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}