summaryrefslogtreecommitdiff
path: root/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'app-portage/unsymlink-lib/unsymlink-lib-16.ebuild')
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-16.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
new file mode 100644
index 000000000000..90b56e60ca45
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_test() {
+ # tests are docker-based
+ :
+}
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}