summaryrefslogtreecommitdiff
path: root/app-portage/tatt/tatt-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/tatt/tatt-0.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/tatt/tatt-0.4.ebuild')
-rw-r--r--app-portage/tatt/tatt-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/tatt/tatt-0.4.ebuild b/app-portage/tatt/tatt-0.4.ebuild
new file mode 100644
index 000000000000..78be3080366b
--- /dev/null
+++ b/app-portage/tatt/tatt-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="arch testing tool"
+HOMEPAGE="https://github.com/kensington/tatt"
+SRC_URI="https://github.com/kensington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-client/pybugz
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}