summaryrefslogtreecommitdiff
path: root/app-portage/tatt/tatt-0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /app-portage/tatt/tatt-0.10.ebuild
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'app-portage/tatt/tatt-0.10.ebuild')
-rw-r--r--app-portage/tatt/tatt-0.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/tatt/tatt-0.10.ebuild b/app-portage/tatt/tatt-0.10.ebuild
new file mode 100644
index 000000000000..39752c13105c
--- /dev/null
+++ b/app-portage/tatt/tatt-0.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Arch testing tool"
+HOMEPAGE="https://github.com/gentoo/tatt"
+SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit[${PYTHON_USEDEP}]
+ app-portage/nattka[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-client/pybugz
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}