summaryrefslogtreecommitdiff
path: root/app-portage/smart-live-rebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-portage/smart-live-rebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-portage/smart-live-rebuild')
-rw-r--r--app-portage/smart-live-rebuild/Manifest3
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild36
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild6
3 files changed, 41 insertions, 4 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
index 05007c900357..d778fdd29e48 100644
--- a/app-portage/smart-live-rebuild/Manifest
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -1,4 +1,5 @@
DIST smart-live-rebuild-1.3.6.tar.gz 17194 BLAKE2B a1c4f07e66ce3328ae70f88d086c33875bed68aea645a180e68fbd997051c6d398c1133d8e9c72378741fe41c519e941e76dc25d9c3f9c61c36531fe6fbe8e79 SHA512 f9fe57269654d69c3b21d0b6e378dfa3d2c00e67dae44278b2b81d631e4645346ecaeb5c9f43b77d39312b97edee247ba8b05303be903d6a3573bc226159c40f
+EBUILD smart-live-rebuild-1.3.6-r1.ebuild 844 BLAKE2B a48e2bc621ef29569abe187caae14d1d55a6ffd0e3555c4e7c31d4ca772d694d52dcbd1ba0e4f3d9bda906bd58ec313f93751596bce6841c5c87127bd137fab7 SHA512 3ee649d13cbc69afcc2956fd401fedb8916099b71f0b1ee4ad128bdcd93445dc8c2153d1f024144ddddf564085f09972960625fa675824f2b2aced85ab05edda
EBUILD smart-live-rebuild-1.3.6.ebuild 841 BLAKE2B fdcb8e95731207501cbb9c77fd4723703f6c7ae9c77f2dc5a05a98021d2b0e782959ca9debb9a4c23e9866b138a16e21310928fc1e798cc0d4ac65b73edf458a SHA512 7148ac3d87795a218e302f855c6cf7e06c1e3ba55233f7aac7b3203034d93ede9ba2a526d5f036c4320456332061a99d51346e3cebaf99b41504e1213b432062
-EBUILD smart-live-rebuild-9999.ebuild 753 BLAKE2B 588296dcb808c927331821d7473fcff22587c71a20adbe903ff7a1fd49453837e486059154b0659457e088cfba7ed8e6ebc873e8b42e153c3e9701cffe77c182 SHA512 a894151cfd2e9e81899f9ec6762b095b9e605e06cb1dc4bb21968995565afc7fb292d03442ea71ed1eeb263082ba9584cd9c1e5066d47537f64604d891420792
+EBUILD smart-live-rebuild-9999.ebuild 753 BLAKE2B 6213e113179dc428d5f5fb5e72a3a3560c8d52c5361655828e709c97c3cec4d9ad3f5590a839bbfc7ca46ddca9548d3f00949e6c6b4d1e8e480c6c883a1f89a0 SHA512 9f3cd7437a551bdf8faa57990143ca422d30f3a5cd5de58e8cfcac701d553df1d2b3cee5c5aba41501d79b3b49f4ccb6abc67be845675376a9285a7e33866b78
MISC metadata.xml 769 BLAKE2B 5aaad83253d55d1096c19aeb6a980e31456ca20a1ecfdb45e93dfd2f72cff7cce61124bf546932266d24d0c9fd0493ae4c61089ab291028360834c2f6d237e5a SHA512 d11c942868f0166c646922088dfecf3047f8ca017b85965382bec8fc794e11d6ffdea27a9156a41faec10a79a13836b13d8b9213a44e57672e1355fbd6bfd0da
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild
new file mode 100644
index 000000000000..ccc36895bd2e
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
index 1f974965eedd..adf1f7f98aec 100644
--- a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{8..9} )
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
inherit distutils-r1 git-r3