summaryrefslogtreecommitdiff
path: root/app-portage/pkg-testing-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-17 23:37:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-17 23:37:36 +0000
commit78fce155315439a69aa67573fd4696b735649431 (patch)
tree8d187eea60a186fececd8ec9c1579a3cacbaca1d /app-portage/pkg-testing-tools
parent95580151e6cfe563d6c0550936c7fd92e24a6acf (diff)
gentoo auto-resync : 17:02:2024 - 23:37:36
Diffstat (limited to 'app-portage/pkg-testing-tools')
-rw-r--r--app-portage/pkg-testing-tools/Manifest3
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild17
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild32
3 files changed, 48 insertions, 4 deletions
diff --git a/app-portage/pkg-testing-tools/Manifest b/app-portage/pkg-testing-tools/Manifest
index 104881348421..3b580817210b 100644
--- a/app-portage/pkg-testing-tools/Manifest
+++ b/app-portage/pkg-testing-tools/Manifest
@@ -5,5 +5,6 @@ DIST pkg-testing-tools-0.2.1.gh.tar.gz 10488 BLAKE2B aa3971115924e4e404b4d25ea5b
EBUILD pkg-testing-tools-0.1.0.ebuild 482 BLAKE2B 862126cbcbf8f6f46f1c7f639275b1896d3c06b1967c0242f31f56fa2a47dc80624957275fc3cba068adee356ac4b8fd878bb5ebac5150dcac293a8873d64a9c SHA512 d25f8e939978d9753f7d22793660b89aefcc784dac0a1615b3745e92e2ddf17aa8087296ae6f228be919fee098d2e3d70ae24c2a6c6da80fef3bef411346241a
EBUILD pkg-testing-tools-0.1.2.ebuild 518 BLAKE2B 7caa3978c5cb7cf644da0d9bca0a7ffaa9adaf8179246090f8bbf3dfac364359a6f06e01335b9a7d598c03e38f851bfe7fbf096db14e17393657533ea29cf9cb SHA512 ac4f272cfe87f3362cb20044304c8d11882f40c72d54ce0f0104aa1bcd72d62aae820eb5c7a273952190449f69b11b19a5d6946828398728391dc9fe7d2e5a9a
EBUILD pkg-testing-tools-0.2.0.ebuild 514 BLAKE2B 1f8840bb12fb9dfe094737715beaea6547898f3f9fb9e37c42614222a0a6c817d0235ae2caae8327ab697e97d5363d743e660022a492b77493d14d2e793a3307 SHA512 a2d96efb141b375caa2862cd383d0d258cbbcd1bba6de11e18f488442a6a6583e7b5612a9f1ff9716b1f584abe979f740c5f27c83f4936667f282de053ca6e78
-EBUILD pkg-testing-tools-0.2.1.ebuild 514 BLAKE2B 1f8840bb12fb9dfe094737715beaea6547898f3f9fb9e37c42614222a0a6c817d0235ae2caae8327ab697e97d5363d743e660022a492b77493d14d2e793a3307 SHA512 a2d96efb141b375caa2862cd383d0d258cbbcd1bba6de11e18f488442a6a6583e7b5612a9f1ff9716b1f584abe979f740c5f27c83f4936667f282de053ca6e78
+EBUILD pkg-testing-tools-0.2.1.ebuild 706 BLAKE2B 4c11f4442905e442197dc6881dff678b052252e55b93f0bea15074e411b5fcd60130d61a62c661401c29301edc63cf51cc49b1157be3b51a4b4b85c400ab6e03 SHA512 dbbbc5d23ccad8e3a87c51d808682d9ff1fdd659c14914259d673e2d17c69bc8c3759db086801726394d7c5cb3a64aa941b413bfe42a5814f4b171f1be33e141
+EBUILD pkg-testing-tools-9999.ebuild 706 BLAKE2B 4c11f4442905e442197dc6881dff678b052252e55b93f0bea15074e411b5fcd60130d61a62c661401c29301edc63cf51cc49b1157be3b51a4b4b85c400ab6e03 SHA512 dbbbc5d23ccad8e3a87c51d808682d9ff1fdd659c14914259d673e2d17c69bc8c3759db086801726394d7c5cb3a64aa941b413bfe42a5814f4b171f1be33e141
MISC metadata.xml 511 BLAKE2B 28c5a606539ab4e39b0113ce58ac6cb8331f54ea459b0d38025873cf14f7eb84a1b170b2c8f352f989270d621620af611fb567c0ee5e400e098c4214fd981b95 SHA512 d0cafe6f9fe869007bf701796d1bceee66fefb6b6e3cfb413ab2a651709d625e117bd5c8e5d23d5647af1f6de95870da6be7344655e7fe15d48d831dba316cea
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
index 41d4e5d3029a..c8cd079994a1 100644
--- a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
@@ -4,18 +4,29 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Packages testing tools for Gentoo"
HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
-SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+REPO=APN-Pucky
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
sys-apps/portage[${PYTHON_USEDEP}]
"
+
+distutils_enable_tests pytest
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
new file mode 100644
index 000000000000..c8cd079994a1
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
+
+REPO=APN-Pucky
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest