summaryrefslogtreecommitdiff
path: root/app-portage/pkg-testing-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /app-portage/pkg-testing-tools
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'app-portage/pkg-testing-tools')
-rw-r--r--app-portage/pkg-testing-tools/Manifest3
-rw-r--r--app-portage/pkg-testing-tools/metadata.xml11
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.1.0.ebuild19
3 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/pkg-testing-tools/Manifest b/app-portage/pkg-testing-tools/Manifest
new file mode 100644
index 000000000000..68637f90b157
--- /dev/null
+++ b/app-portage/pkg-testing-tools/Manifest
@@ -0,0 +1,3 @@
+DIST pkg-testing-tools-0.1.0.tar.gz 6131 BLAKE2B 6d8dddb81e57159df9f2e1897718433d29f330286afb868a1111db4e0bb7a53823df57a5d7084a24fd5807787f169fff137f5c6c0bdcddeec2c59090d9b90775 SHA512 05165d3790b4d38c939226d1149c0c44cd62fe222a199bce8f1e108d12475710f8482f82e2e2e45223ba24fd1b50451dea8b3761c8f474a59e660b9a67bf8ab4
+EBUILD pkg-testing-tools-0.1.0.ebuild 465 BLAKE2B d362da60f16f83e11506faf4d84926a67e54ffb69be5357bc63217c1c3198342a9b7dae2e2f341d6747d694dcacbfa91b432ea80d83167308349afc9b1a2494e SHA512 1ef64be6b39128ff352d7492667c56bbf8d4fb0190c0584069dc609a98652476311a1c5d8c807b68f3c62bd6e517e935df5db12a198ecd42be72fbc8c0c3eeba
+MISC metadata.xml 345 BLAKE2B d80bdd7996aa73b0085e2f5656b8d302ee936da562e45775785c1543719b8298823a50d437da0a2d7e0037919f607146eeae310cb95b7984737b4891635ee7cf SHA512 ddbe8a257ac698a25d13e84833682b35f55252da02985caf9cc40c289bdaf6001382c9a018c39d824f37727fc7b0a8f9930e509554fb740b151b4120fcc6fee6
diff --git a/app-portage/pkg-testing-tools/metadata.xml b/app-portage/pkg-testing-tools/metadata.xml
new file mode 100644
index 000000000000..4a891574f8ce
--- /dev/null
+++ b/app-portage/pkg-testing-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">slashbeast/pkg-testing-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.1.0.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.1.0.ebuild
new file mode 100644
index 000000000000..a6616c032088
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/slashbeast/pkg-testing-tools"
+SRC_URI="https://github.com/slashbeast/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"