summaryrefslogtreecommitdiff
path: root/app-portage/overlint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/overlint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/overlint')
-rw-r--r--app-portage/overlint/Manifest5
-rw-r--r--app-portage/overlint/metadata.xml8
-rw-r--r--app-portage/overlint/overlint-0.5.2.ebuild19
-rw-r--r--app-portage/overlint/overlint-0.5.3-r1.ebuild23
4 files changed, 55 insertions, 0 deletions
diff --git a/app-portage/overlint/Manifest b/app-portage/overlint/Manifest
new file mode 100644
index 000000000000..b74f68087cf8
--- /dev/null
+++ b/app-portage/overlint/Manifest
@@ -0,0 +1,5 @@
+DIST overlint-0.5.2.tar.gz 2701 BLAKE2B 28fe90628d1c6603af0936b7a5d945b39bd93b3a7444bee7ac79bb939d8c108a32f58ce51fe10198564d24927bb7c04e273de83417c77ec38d3442562a7a2a7b SHA512 aae78ed2d3f02e83ced3dbe8ace468adb204b80e040b979a97d92af0c91e79019f2ed14e6e3655ffa8137c55c8fd1f054c27229819ae7908632586acb284f3ea
+DIST overlint-0.5.3.tar.gz 2706 BLAKE2B 78c76a72556213bbc84b91ada3ea1d71ad045fe4498baab1f6710190a55802e5ffee14d652540d2cb7caaecd407963f7bad9682cb72e5e6571597983384bf019 SHA512 348b59e5f013b1c4060312208fdc7fddad3252d6f386513d743b7685d8aafbf76ac626fb9000c2d47c362b85d223dea5f59b4cfec55dbf24a52185c5b943a149
+EBUILD overlint-0.5.2.ebuild 466 BLAKE2B c916134cbe58ada2432a06f4be63496eba7f66ccc2943eca889dd5fefad9340ae432b824749d199ac49a5904a819a7c3bc06f143f1c16afc1ca5bd2ef8ff43bf SHA512 14bb74721903f33da9fbe1c44892b631553e14d36f8ecf05de11ee331006b6523d5d24305943904bfde815a6396d7b3f1cd6482de16eb0d2a9ea438199cc3742
+EBUILD overlint-0.5.3-r1.ebuild 543 BLAKE2B 98f28a6fe5bab8f66a0a9ed4b5a811822a80a2d0c7b3b3cbfae5d7875afd78d10735ab5293d271a0fa7ec1eb1d8ad8682ed7224e34fabee3ca8c9edaf9f9ded8 SHA512 ea3665a033c1040b741cd206af229872d16580abb2c99b13fb6aea42d7f5deb93b0f667ad4671a8d53351b0af9e5498c0abac12ab3bcfac431416cbd8050e137
+MISC metadata.xml 249 BLAKE2B 3647e2ef94ad009c86dc9d42c1396ad9420ade97042882b8d8f60f676c465cfd6ea3cea4b77caccadd99eb0cbe1ef83b18b799ec676da4ecfbff528d21bb5ffb SHA512 334ac61f9acc5c4917fd29afb3b420b1689b39be80cada419bed1db033e64130866d0995abe5f1c75eb1290f51734e9ad4c8d06fd8b49c288ecf617a0693d273
diff --git a/app-portage/overlint/metadata.xml b/app-portage/overlint/metadata.xml
new file mode 100644
index 000000000000..6d2298876faa
--- /dev/null
+++ b/app-portage/overlint/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-portage/overlint/overlint-0.5.2.ebuild b/app-portage/overlint/overlint-0.5.2.ebuild
new file mode 100644
index 000000000000..bad334ae475d
--- /dev/null
+++ b/app-portage/overlint/overlint-0.5.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple tool for static analysis of overlays"
+HOMEPAGE="https://cgit.gentoo.org/proj/overlint.git"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-apps/portage"
diff --git a/app-portage/overlint/overlint-0.5.3-r1.ebuild b/app-portage/overlint/overlint-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..c21a4821b5d1
--- /dev/null
+++ b/app-portage/overlint/overlint-0.5.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple tool for static analysis of overlays"
+HOMEPAGE="https://cgit.gentoo.org/proj/overlint.git"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"