summaryrefslogtreecommitdiff
path: root/app-portage/iwdevtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /app-portage/iwdevtools
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest2
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 134a622a6dd0..c135c511715d 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,4 +1,6 @@
DIST iwdevtools-0.12.0.tar.gz 88411 BLAKE2B 9220d59ee9ec7305925798d8beafec49ef35d8e39a428b62df3b3ed3832da1e42aff5e94ab8c5cfd85272d21cbb13c856408cf665523f8b1de85818ba08aebc4 SHA512 b69face29355df2443e75101b81c477dfdb1f54aad14f0d6275c399bd97cd654c4819f5621177d7ef75ecc4540e923ee5cd42f806240ed346ab469959f6a38d9
+DIST iwdevtools-0.12.1.tar.gz 88857 BLAKE2B 885909b20729279f5d711c65e915078995d0b2d26170f12e6669e499ee42f8a6bd8b5d59930215a3f39f60a1a0b5970f31548d33e059ae314fa1520971bb990a SHA512 3046a661718afbec305dda20990be258a4df981b3a72d49b77384f7a23d8c22e295bb99717c69a4569b6ab3a4195c6dbca0c07b3675bbb78a98aa0a198994988
EBUILD iwdevtools-0.12.0.ebuild 1907 BLAKE2B 5cce7273be85fbd5ff5b3aa468086c23612e40e54ff7acf456311e07aa4ab39e597424f23b94c6b56912c9b1252e72cd7c12e8d14f654f91eb636bb63909177a SHA512 698c0530e9dcdac227d14000ebf845f9c1919a0801aee12818ea5588e30276ad57fb8480a920976c91b020cbd80cefcb143ff8446454f18222dfeed46bd5b6f4
+EBUILD iwdevtools-0.12.1.ebuild 1915 BLAKE2B a98ac7ead6f494052f08e6dbd20f34866bfe2481d252c43cc94d31f75fb0b4bf24c6f6f1d73a2b5dcc4c76e2fb1e1b5d14b0b58af4162c1f27183b73ba8daa66 SHA512 6da66aa4d2ea4d6e040636a8b189f8d3fc83662a4a042472a8bbad9202fb8849595cae99a41a55a924c8a094e1bdc0392050d40f294b398a4139fd149c33c5e4
EBUILD iwdevtools-9999.ebuild 1806 BLAKE2B 90e7cd55d1f57c126a6c59489b4bfacf39266a48875370659693efcdd90fef644bbc21e67ecb21c665000139b28008c3d0979796b7f2f2312ca2deebb3860250 SHA512 56e8546414c77b124a5da1b334833384bf2e78adfc385918f6a05a336d1a22cae705d3e526846b8e7a483f929fb9327288d9527c9c157a607a69c362743d9d11
MISC metadata.xml 354 BLAKE2B 752c8fbf18967fb380f0f5d460396222f5fea3f0c7b9ed960ff0dbe62a9a505a2d07c45750aaa55285d11169e01f5e83b82eb278b12fbc5e9c43353c0a5fc9ed SHA512 d8e5866d89b7f05a5a8cd8cc464083d3d096b4c03f8a83e9314dcf45e57c25369bf8a3bc725aed3b8db9f3f86e76bad358bfa58f1eca70f7ec0bf3d31286c2c3
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.1.ebuild
new file mode 100644
index 000000000000..f618116f15e0
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}