summaryrefslogtreecommitdiff
path: root/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /app-portage/iwdevtools/iwdevtools-0.1.1.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'app-portage/iwdevtools/iwdevtools-0.1.1.ebuild')
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild
new file mode 100644
index 000000000000..8886d7139126
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+
+src_configure() {
+ meson_src_configure -Ddocdir=${PF}
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ fi
+}