summaryrefslogtreecommitdiff
path: root/app-portage/gs-pypi/gs-pypi-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/gs-pypi/gs-pypi-0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/gs-pypi/gs-pypi-0.1.ebuild')
-rw-r--r--app-portage/gs-pypi/gs-pypi-0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/gs-pypi/gs-pypi-0.1.ebuild b/app-portage/gs-pypi/gs-pypi-0.1.ebuild
new file mode 100644
index 000000000000..dae5eca3555d
--- /dev/null
+++ b/app-portage/gs-pypi/gs-pypi-0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="g-sorcery backend for pypi packages"
+HOMEPAGE="https://github.com/jauhien/gs-pypi"
+SRC_URI="https://github.com/jauhien/gs-pypi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-portage/g-sorcery[$(python_gen_usedep 'python*')]
+ dev-python/beautifulsoup:4[$(python_gen_usedep 'python*')]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman docs/*.8
+}