summaryrefslogtreecommitdiff
path: root/app-portage/gpyutils/gpyutils-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /app-portage/gpyutils/gpyutils-0.6.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'app-portage/gpyutils/gpyutils-0.6.ebuild')
-rw-r--r--app-portage/gpyutils/gpyutils-0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/gpyutils/gpyutils-0.6.ebuild b/app-portage/gpyutils/gpyutils-0.6.ebuild
new file mode 100644
index 000000000000..07c9616731d5
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="
+ https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}