summaryrefslogtreecommitdiff
path: root/app-portage/gentoolkit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-11 01:28:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-11 01:28:44 +0100
commitb46b9834b3fbf80b22ccc12e95f660512cd0fa75 (patch)
treef7eb18ccc89e078e2f175e5249fe0d4dfdb5b104 /app-portage/gentoolkit/files
parent62f7102650b24618880e8e6f08fcb8fbd235025b (diff)
gentoo auto-resync : 11:07:2022 - 01:28:44
Diffstat (limited to 'app-portage/gentoolkit/files')
-rw-r--r--app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch b/app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch
new file mode 100644
index 000000000000..8039864d69f9
--- /dev/null
+++ b/app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch
@@ -0,0 +1,47 @@
+From 5b52ee6c6efab68111d128d45f386ac21eaf84f6 Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Sun, 10 Jul 2022 13:41:36 -0700
+Subject: [PATCH] Revert "setup.py: migrate to setuptools"
+
+This reverts commit bbbde97b5e625a49a1a66e307931548cb33f260b.
+setuptools only installs data files to the python pkg directory
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 36995de..23e9b36 100755
+--- a/setup.py
++++ b/setup.py
+@@ -3,8 +3,8 @@
+ import re
+ import sys
+ import subprocess
+-
+-from setuptools import setup, Command
++from distutils import core
++from distutils.cmd import Command
+ from glob import glob
+
+ import os
+@@ -67,7 +67,7 @@ manpages = [
+ ]
+
+
+-class set_version(Command):
++class set_version(core.Command):
+ """Set python __version__ and bash VERSION to our __version__."""
+
+ description = "hardcode scripts' version using VERSION from environment"
+@@ -130,7 +130,7 @@ test_data = {
+ ]
+ }
+
+-setup(
++core.setup(
+ name="gentoolkit",
+ version=__version__,
+ description="Set of tools that work with and enhance portage.",
+--
+libgit2 1.4.3
+