summaryrefslogtreecommitdiff
path: root/app-portage/gemato
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /app-portage/gemato
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest4
-rw-r--r--app-portage/gemato/gemato-4.ebuild30
-rw-r--r--app-portage/gemato/gemato-9999.ebuild31
-rw-r--r--app-portage/gemato/metadata.xml20
4 files changed, 85 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
new file mode 100644
index 000000000000..55b5b2a76e63
--- /dev/null
+++ b/app-portage/gemato/Manifest
@@ -0,0 +1,4 @@
+DIST gemato-4.tar.gz 57334 BLAKE2B 5aad3950e8b7fcf42d088de3b9dd5ded5eaeeb3f91414c38b79eaa4afd4799ccb4084da8a8bdf1bec67b82de8dd09a4c2977f07932a4c63bc833916d184418eb SHA512 a6747a83020efe72ad356873b1648bcf80828efaf9248e17e46cf626f879ebb77571c28d4097ebe56f891a0c096a81feed84bacbd04b37e6a6ce5f0ec37d27ba
+EBUILD gemato-4.ebuild 1074 BLAKE2B 233770f5bee68f35b1828a0e77c2492054f5f4ea480e65e20354b8feecb53b6ee1ae9ad7c8f4069cd5b1edcc1e7b3befd964b8b1d0c436c0bf9679a0ff6cd03c SHA512 a3b9fd69839fd3b33d75a8e597c77314b774539104fecb5f481c43ddc0ded03bf4ee0742fc41d0babf7895f8db993b9fa9256263807b4aff83066e82e9f474e3
+EBUILD gemato-9999.ebuild 1054 BLAKE2B 8f3e8fa2ef281aa0fd09b93d13672fdaed6b16bcc0d5f9546e5a155013a632f970d25e97026acd56c873c41805de7ff947408eb112baa4db594f1ea2ed4f1d00 SHA512 5b956ac5b396a601084f93c67e0de8e5e0ed5578235e80b728ec43c939198e0608011b2183c97d7da5795a1467cd3fbf3390805a135ef7f820e7323e638a864b
+MISC metadata.xml 670 BLAKE2B 8495c32b74bb84f14d4fdd19fefd5c852534547fff65656f76290f019ddb2412453da59195bf67bd596acdd4f24b9f4fbb1d357375fd9ab1d83466e8479f53c4 SHA512 fc2549228500c0829f6e53e011cf46bee9bd3e5b234ceb73e3ef9c4ca3b3755ec3dbdbd86ff9c16ae65bf40329c47e9d6c4b7d78c810e609a50ad508c2776851
diff --git a/app-portage/gemato/gemato-4.ebuild b/app-portage/gemato/gemato-4.ebuild
new file mode 100644
index 000000000000..b5c0440f4f0a
--- /dev/null
+++ b/app-portage/gemato/gemato-4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# backports.lzma is broken with pypy
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="https://github.com/mgorny/gemato/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3"
+
+RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
new file mode 100644
index 000000000000..2df8e801b285
--- /dev/null
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# backports.lzma is broken with pypy
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+blake2 bzip2 +gpg lzma sha3"
+
+RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/app-portage/gemato/metadata.xml b/app-portage/gemato/metadata.xml
new file mode 100644
index 000000000000..23ea67a25989
--- /dev/null
+++ b/app-portage/gemato/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name='blake2'>Install dependencies needed for BLAKE2 hash
+ functions</flag>
+ <flag name='gpg'>Install dependencies needed for OpenPGP
+ signature verification support</flag>
+ <flag name='sha3'>Install dependencies needed for SHA3 hash
+ functions</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/mgorny/gemato/issues/</bugs-to>
+ <remote-id type="github">mgorny/gemato</remote-id>
+ </upstream>
+</pkgmetadata>