summaryrefslogtreecommitdiff
path: root/app-portage/gemato/gemato-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-portage/gemato/gemato-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/gemato/gemato-9999.ebuild')
-rw-r--r--app-portage/gemato/gemato-9999.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
deleted file mode 100644
index d58dc34eb2e5..000000000000
--- a/app-portage/gemato/gemato-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# pyblake2 & pysha3 are broken with pypy3
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-PYTHON_REQ_USE='threads(+)'
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
-
-MODULE_RDEPEND="
- blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
- bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
- gpg? ( app-crypt/gnupg )
- lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
-
-RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
- test? ( ${MODULE_RDEPEND} )"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use tools; then
- exeinto /usr/share/gemato
- doexe utils/*.{bash,py}
- fi
-}