summaryrefslogtreecommitdiff
path: root/app-portage/gemato/gemato-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-17 23:18:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-17 23:18:13 +0100
commita0d1bdbd841fa761e38f468e1009cd058af305fd (patch)
tree7e025c4f7b68d5b31d24058f9e029c18da4db031 /app-portage/gemato/gemato-9999.ebuild
parent5b9522db2ae57aa61163fb9aff331742e9e22330 (diff)
gentoo auto-resync : 17:09:2022 - 23:18:12
Diffstat (limited to 'app-portage/gemato/gemato-9999.ebuild')
-rw-r--r--app-portage/gemato/gemato-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index d889559f38d7..eeeb152eb331 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE='threads(+)'
@@ -16,20 +17,24 @@ EGIT_REPO_URI="https://github.com/projg2/gemato.git"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS=""
-IUSE="+gpg tools"
+IUSE="+gpg pretty-log tools"
RDEPEND="
gpg? (
>=app-crypt/gnupg-2.2.20-r1
dev-python/requests[${PYTHON_USEDEP}]
- )"
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
BDEPEND="
test? (
>=app-crypt/gnupg-2.2.20-r1
- >=dev-python/pytest-5[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest