summaryrefslogtreecommitdiff
path: root/app-portage/gemato/gemato-14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-portage/gemato/gemato-14.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-portage/gemato/gemato-14.1.ebuild')
-rw-r--r--app-portage/gemato/gemato-14.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-portage/gemato/gemato-14.1.ebuild b/app-portage/gemato/gemato-14.1.ebuild
deleted file mode 100644
index 96d59a16d5c9..000000000000
--- a/app-portage/gemato/gemato-14.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# pyblake2 & pysha3 are broken with pypy3
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
-PYTHON_REQ_USE='threads(+)'
-inherit distutils-r1
-
-DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
-RESTRICT="!test? ( test )"
-
-MODULE_RDEPEND="
- blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )
- bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
- gpg? ( app-crypt/gnupg )
- lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )"
-
-RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
- test? ( ${MODULE_RDEPEND} )"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use tools; then
- exeinto /usr/share/gemato
- doexe utils/*.{bash,py}
- fi
-}