summaryrefslogtreecommitdiff
path: root/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 22:13:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 22:13:48 +0000
commit97975d199eba29b1b2f09f99dcd0566f2d1f581f (patch)
treee745f623575a90f1608f613dedfc4e441092909e /app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild
parente65ee315554600740a3ecc9dde351e7ded136023 (diff)
gentoo auto-resync : 05:11:2023 - 22:13:48
Diffstat (limited to 'app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild')
-rw-r--r--app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild
new file mode 100644
index 000000000000..788a228fffb1
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
+HOMEPAGE="https://github.com/hartwork/fetchcommandwrapper"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=net-misc/aria2-1.10.2[metalink,xmlrpc]"
+
+pkg_postinst() {
+ ewarn 'You need to append'
+ ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
+ ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
+}