summaryrefslogtreecommitdiff
path: root/app-portage/euscan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/euscan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/euscan')
-rw-r--r--app-portage/euscan/Manifest4
-rw-r--r--app-portage/euscan/euscan-0.1.1-r2.ebuild36
-rw-r--r--app-portage/euscan/euscan-9999.ebuild36
-rw-r--r--app-portage/euscan/metadata.xml11
4 files changed, 87 insertions, 0 deletions
diff --git a/app-portage/euscan/Manifest b/app-portage/euscan/Manifest
new file mode 100644
index 000000000000..8d486f3f6a24
--- /dev/null
+++ b/app-portage/euscan/Manifest
@@ -0,0 +1,4 @@
+DIST euscan-0.1.1.tar.gz 441780 BLAKE2B 7c0603cca9b9da1f849999b215db2d397656ffc1e8e87193174e6ada548497f1ebb30252f83d0fb4dbbfa92000480947b1731f1792d8612e1ad56fd56daa2b54 SHA512 2f55f8f4b0fd46b13c981ba94be29a62f16fe2890ce03f99ac14b1488c2ebb59abdaee12f671d679b934b4fd875ee27e751d2c305420f7cfb08e69ec899a75ab
+EBUILD euscan-0.1.1-r2.ebuild 863 BLAKE2B cbc6710b4911fcaa58c1a32ae90859571e45f6301e434e76d0f576f3fa57e2e56ca89c1c0cb18f7c82e119bedfb14613324db5209b4042cbad4bbed7b9f81a39 SHA512 b1a802d02693afed7d393823b88760c41a7b67da8dc67f194dc42f58a9a2cd1e510bb3ca21fd5d6fd2c9d77ded0bd4b1cfdff4f59894030e0c742f83e6486fd0
+EBUILD euscan-9999.ebuild 816 BLAKE2B ccba573b5a4740c44ce9d39ab050b4deb0d06ef901cb5556dc1a04249d943b79849f63e3f63e07f9983ec913466a6649697dddcc34caaa577d056d6c2409138a SHA512 b366831123590d0ee27951147a9f7ac66c8cc2df6a83c03539317e58c9f6377f6deac80231056d90304a24de2d0472fbc01d56a369e77ad0a8bfe8b0b05cab62
+MISC metadata.xml 340 BLAKE2B 9429176a710bbd82a9c4bfdbf3228422807daa00564201eec1d8bfa2a1b76f65b84e16e6083cb0847bed08745262f0b95b8563b7449e69be95d8bc2ecdba6d1c SHA512 de74198fe372171f19b6486164e81b3f256ae6a04451ce5c3c789909a0a3bff6ec15a42a3cf3387f227cef33f8dbb32eb9872af95d6f962f61ecd2fa64ad0b5d
diff --git a/app-portage/euscan/euscan-0.1.1-r2.ebuild b/app-portage/euscan/euscan-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..27566cc7555f
--- /dev/null
+++ b/app-portage/euscan/euscan-0.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Ebuild upstream scan utility"
+HOMEPAGE="https://github.com/iksaif/euscan"
+SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
diff --git a/app-portage/euscan/euscan-9999.ebuild b/app-portage/euscan/euscan-9999.ebuild
new file mode 100644
index 000000000000..c71e1ee07ef8
--- /dev/null
+++ b/app-portage/euscan/euscan-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Ebuild upstream scan utility"
+HOMEPAGE="https://github.com/iksaif/euscan"
+EGIT_REPO_URI="https://github.com/iksaif/euscan.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
diff --git a/app-portage/euscan/metadata.xml b/app-portage/euscan/metadata.xml
new file mode 100644
index 000000000000..2c94ca18e808
--- /dev/null
+++ b/app-portage/euscan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>patrick@gentoo.org</email>
+</maintainer>
+<maintainer type="person">
+ <email>alicef@gentoo.org</email>
+ <name>Alice Ferrazzi</name>
+</maintainer>
+</pkgmetadata>