summaryrefslogtreecommitdiff
path: root/app-portage/elogviewer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/elogviewer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/elogviewer')
-rw-r--r--app-portage/elogviewer/Manifest5
-rw-r--r--app-portage/elogviewer/elogviewer-2.7-r2.ebuild64
-rw-r--r--app-portage/elogviewer/elogviewer-2.9.ebuild64
-rw-r--r--app-portage/elogviewer/metadata.xml16
4 files changed, 149 insertions, 0 deletions
diff --git a/app-portage/elogviewer/Manifest b/app-portage/elogviewer/Manifest
new file mode 100644
index 000000000000..b1f86b4e6bcf
--- /dev/null
+++ b/app-portage/elogviewer/Manifest
@@ -0,0 +1,5 @@
+DIST elogviewer-2.7.tar.gz 19936 BLAKE2B 530c3324666089af93712a17f01cc9b6284b2639b4e768a41461da35d615ee1a75870a4138587d85d4eff4925945dee45dbc1af848b7fc500165c8e96d3c7d01 SHA512 81cf20e8e5509d83634d601f0920bd369e1974c843b600b54faa433dc9927a0df6c9820d2b1f35b241bcd86ea891945f16ec2b0d1b65d08c085a3b245c8b038d
+DIST elogviewer-2.9.tar.gz 24157 BLAKE2B ff527c0198e86f7be15fce3f25f0e9677b6911cef72cfdc1f582c62f534fc15adac8c2cf612475f174561dd46b489dcaf819c8ccd1b5893adeb7a6c085ce11c2 SHA512 e5781eeaf663fafa680b0620c4a6aec63afffd05c1cb4cb5362e9eca3a35c85550ee295a6b753155b0392d69442068cf155c3ead872c457e5a3cdbcd59b1ab2e
+EBUILD elogviewer-2.7-r2.ebuild 1761 BLAKE2B 24b9e45586dd521da1b84e60eaee1e8d921ed0af3aa15daa1c4edaaf5e870606ffea71fcf0ec0542fdf670e89d1708125b0a6a3d67bb2fa75b976a737a2c0276 SHA512 0da80252b934601cbc96e17ee918ad15ed853d9f1155451473ef3cd3da0e733ddf7293e83974be2ce6a0ffd502269c570a0f7ff5e917a0a8eef9b77385eeb153
+EBUILD elogviewer-2.9.ebuild 1765 BLAKE2B 429d7a92fa9cc64532c0e543a29b011f0d5d3e49ec321223398aafe2bbfc5bacfaa96fdb633860a8f7ec9c1d42e46019dd16bc5e258fdd645466f06b6601000d SHA512 db42ed22dc07cfb77d874a5c3dfe58b5d8e5269016388e38994edb1103e3298687e581cb152e7f42c6c051e176e38fe456bb67ef7fbd20ecbb00559756ee5329
+MISC metadata.xml 508 BLAKE2B 4414a5567ae33626032ceec6a059d7547bf8f2b69bc561b08e7ce60817194cd646813e0d3d0debc88ca10b85933ecbbdf954cbfe4d6b4194499e866ce54d7271 SHA512 bcea5d31473ddfb682d52f604f8eec6ec26938a30a62f7388e9b3be36d17a8f189ea97c418708b88949a6d48e10f6652feabbd247eeb9ef9132ce20916c41ec8
diff --git a/app-portage/elogviewer/elogviewer-2.7-r2.ebuild b/app-portage/elogviewer/elogviewer-2.7-r2.ebuild
new file mode 100644
index 000000000000..c2a6997e1742
--- /dev/null
+++ b/app-portage/elogviewer/elogviewer-2.7-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+DISABLE_AUTOFORMATTING=true
+
+inherit python-single-r1 eutils readme.gentoo-r1
+
+DESCRIPTION="Elog viewer for Gentoo"
+HOMEPAGE="https://sourceforge.net/projects/elogviewer"
+SRC_URI="https://github.com/Synss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ || (
+ >=sys-apps/portage-2.1[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOC_CONTENTS="In order to use this software, you need to activate
+Portage's elog features. Required is
+ PORTAGE_ELOG_SYSTEM=\"save\"
+and at least one of
+ PORTAGE_ELOG_CLASSES=\"warn error info log qa\"
+More information on the elog system can be found in
+/usr/share/portage/config/make.conf.example
+
+To operate properly this software needs the directory
+${PORT_LOGDIR:-/var/log/portage}/elog created, belonging to group portage.
+To start the software as a user, add yourself to the portage group."
+
+src_compile() {
+ rm -f Makefile
+}
+
+src_install() {
+ python_newscript elogviewer.py elogviewer
+
+ make_desktop_entry ${PN} ${PN} ${PN} System
+
+ doman elogviewer.1
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ ewarn "The elogviewer's configuration file is now saved in:"
+ ewarn "~/.config/elogviewer/ (was ~/.config/Mathias\ Laurin/)."
+ ewarn "Please migrate any user specific settings to the new config file."
+}
diff --git a/app-portage/elogviewer/elogviewer-2.9.ebuild b/app-portage/elogviewer/elogviewer-2.9.ebuild
new file mode 100644
index 000000000000..a97ff3d045b8
--- /dev/null
+++ b/app-portage/elogviewer/elogviewer-2.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+DISABLE_AUTOFORMATTING=true
+
+inherit python-single-r1 eutils readme.gentoo-r1
+
+DESCRIPTION="Elog viewer for Gentoo"
+HOMEPAGE="https://sourceforge.net/projects/elogviewer"
+SRC_URI="https://github.com/Synss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ || (
+ >=sys-apps/portage-2.1[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOC_CONTENTS="In order to use this software, you need to activate
+Portage's elog features. Required is
+ PORTAGE_ELOG_SYSTEM=\"save\"
+and at least one of
+ PORTAGE_ELOG_CLASSES=\"warn error info log qa\"
+More information on the elog system can be found in
+/usr/share/portage/config/make.conf.example
+
+To operate properly this software needs the directory
+${PORT_LOGDIR:-/var/log/portage}/elog created, belonging to group portage.
+To start the software as a user, add yourself to the portage group."
+
+src_compile() {
+ rm -f Makefile
+}
+
+src_install() {
+ python_newscript elogviewer.py elogviewer
+
+ make_desktop_entry ${PN} ${PN} ${PN} System
+
+ doman elogviewer.1
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ ewarn "The elogviewer's configuration file is now saved in:"
+ ewarn "~/.config/elogviewer/ (was ~/.config/Mathias\ Laurin/)."
+ ewarn "Please migrate any user specific settings to the new config file."
+}
diff --git a/app-portage/elogviewer/metadata.xml b/app-portage/elogviewer/metadata.xml
new file mode 100644
index 000000000000..7144a8404ae4
--- /dev/null
+++ b/app-portage/elogviewer/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>tools-portage@gentoo.org</email>
+ <name>Gentoo Portage tools team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">elogviewer</remote-id>
+ <remote-id type="github">Synss/elogviewer</remote-id>
+ </upstream>
+</pkgmetadata>