summaryrefslogtreecommitdiff
path: root/app-portage/elogv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-portage/elogv
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-portage/elogv')
-rw-r--r--app-portage/elogv/Manifest1
-rw-r--r--app-portage/elogv/elogv-0.7.8-r3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-portage/elogv/Manifest b/app-portage/elogv/Manifest
index 0746033e48c3..b794f996eb52 100644
--- a/app-portage/elogv/Manifest
+++ b/app-portage/elogv/Manifest
@@ -1,4 +1,5 @@
DIST elogv-0.7.8.tar.gz 19554 BLAKE2B 653a1dd8d5cb142c78c27ad4c7110a7dac666eed649213ef62c1548d5248c4add561242290a59178470736cffc9ac15fb7ee796a2954239ba382001f1e6c9c4f SHA512 be90f01b4d2e114608b13aeba78ab368af6ed66ca329de6952d7f422c90356fd1c6988827f0c60ee66636ae92e089689c7cbd725f6eb20545747fb24d0d1daf2
EBUILD elogv-0.7.8-r1.ebuild 1591 BLAKE2B 02a2079dc2bb538acce711cf185fdbae073af455262250eeacee9cf125ca0d8ec77b2636da279c42fef093654ab338f41553d387c1cbc1c543a644750f275c17 SHA512 c419b695f0db6cbc505eccc4225ee77a446b253a1997dc10f9b18d1bedccf3a6b2d46c9a87f7ecc13c7d5959a8c07ea9a5023ec89af964ab84081eada91c94db
EBUILD elogv-0.7.8-r2.ebuild 1663 BLAKE2B d0945ca00a2a998ffc3a20e2ccd3a96fc69f609b6f640360f0302b621ce85734d79f88c61cd9796b2252292c5f92bad0458fac80e7830580004ac4362342bb4d SHA512 1706f0b8e7f3a0da7834f74d2245a7f1888c80f0ec93056526c6508e2300aa373f247db1139aa9d0d43482c1b476fae6b6566a85d17f78ef6712103286e33a73
+EBUILD elogv-0.7.8-r3.ebuild 1692 BLAKE2B bd822694ff56a02720cef2d647991b5db8b3cd390742a433d632856a33097c13f4a1e7718c38820f4114ceea58f5aba0790596272ccc9d98ac36298cea747530 SHA512 b2b411f8e526ad9d950dc7db9f7043f9c84a8187efa498d6bc60bca958a1c0c0540caac8683d421845310c6e426e1003a9cc0eb33b9bcbc5cb01027ca21c09c3
MISC metadata.xml 470 BLAKE2B b80ae78f2033fbe4623e47b9f24581e2781a374cb9b85ceb9f990b2505666c19cb003050dea8dd532c1641c0c4fc27d84347ec39c5a5624bf79adba1e42ab873 SHA512 ad99227415869525deb25fc3cd2ead8023a03cddd0d546d14a8669cd681e5aa47cc40977a1664d466aa40c6100479e24e1228b3761ff331bc2436443e9c1443c
diff --git a/app-portage/elogv/elogv-0.7.8-r3.ebuild b/app-portage/elogv/elogv-0.7.8-r3.ebuild
new file mode 100644
index 000000000000..9bb9e95bbc71
--- /dev/null
+++ b/app-portage/elogv/elogv-0.7.8-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Curses based utility to parse the contents of elogs created by Portage"
+HOMEPAGE="https://github.com/gentoo/elogv"
+SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+
+src_install() {
+ distutils-r1_src_install
+
+ # unset LINGUAS => install all languages
+ # empty LINGUAS => install none
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(ls "${ED}"/usr/share/locale/) ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm -rf "${ED}"/usr/share/{locale,man}/${i}
+ fi
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "Optional dependencies:"
+ elog " dev-python/pyliblzma (for xz compressed elog files)"
+ elog
+ elog "In order to use this software, you need to activate"
+ elog "Portage's elog features. Required is"
+ elog " PORTAGE_ELOG_SYSTEM=\"save\" "
+ elog "and at least one out of "
+ elog " PORTAGE_ELOG_CLASSES=\"warn error info log qa\""
+ elog "More information on the elog system can be found"
+ elog "in ${EPREFIX}/usr/share/portage/config/make.conf.example"
+ elog
+ elog "To operate properly this software needs the directory"
+ elog "${PORT_LOGDIR:-${EPREFIX}/var/log/portage}/elog created, belonging to group portage."
+ elog "To start the software as a user, add yourself to the portage"
+ elog "group."
+ elog
+}