summaryrefslogtreecommitdiff
path: root/app-portage/elicense
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
commit6f8038813c460b4f0572d5ef595cdfa94af3a94d (patch)
tree3509e94070265053394b7f2e30a779d7e60c2064 /app-portage/elicense
parenteccb70a7f91b2d22582587f26d1a28bb31408b45 (diff)
gentoo resync : 21.05.2019
Diffstat (limited to 'app-portage/elicense')
-rw-r--r--app-portage/elicense/Manifest4
-rw-r--r--app-portage/elicense/elicense-1.0.0.ebuild23
-rw-r--r--app-portage/elicense/elicense-9999.ebuild23
-rw-r--r--app-portage/elicense/metadata.xml12
4 files changed, 62 insertions, 0 deletions
diff --git a/app-portage/elicense/Manifest b/app-portage/elicense/Manifest
new file mode 100644
index 000000000000..e37b984fc18c
--- /dev/null
+++ b/app-portage/elicense/Manifest
@@ -0,0 +1,4 @@
+DIST elicense-1.0.0.tar.gz 8719 BLAKE2B 4d9c06cf3229f5a13ec246080098e1f8389afa951bf95cce48159509c160bbc43da511ec0936139c282f59514419fc4911b6a7c9c89bdce18ccda8d175baacae SHA512 5b81e9256486f42f9060d29c7ba3c9101a23a60bfc1ceed978172a2d6feeda22e42486b950ee181a3fe5166e69cabc0ba29043811076865b38f687c0258e9aa8
+EBUILD elicense-1.0.0.ebuild 695 BLAKE2B c9a2e729e957e9a856c08fa90fdaf903f62e4f9068279775a8932897aabf71b4c3800c17ec485a0526caae57a8d74a8d43ff4237141816b37b9d9e0b2e9b4e7d SHA512 8fc2dc5be6ad20d05d3c8fb25d1ffbe24e9db5651ce92ac4a6fd9f7261e5cd69372a130c086ff982d90b06d488e110cf39bfc53ff5cd8812523bfb28f4fbec2f
+EBUILD elicense-9999.ebuild 695 BLAKE2B c9a2e729e957e9a856c08fa90fdaf903f62e4f9068279775a8932897aabf71b4c3800c17ec485a0526caae57a8d74a8d43ff4237141816b37b9d9e0b2e9b4e7d SHA512 8fc2dc5be6ad20d05d3c8fb25d1ffbe24e9db5651ce92ac4a6fd9f7261e5cd69372a130c086ff982d90b06d488e110cf39bfc53ff5cd8812523bfb28f4fbec2f
+MISC metadata.xml 355 BLAKE2B 3b6e208a86ad1c40713f9e441d5ec81de0040c146d4cdfd1e1026d550dda0177ae659120ee272d84035fe9fbfc0d2089a7f2726056247710530db9b59e4ae1d2 SHA512 2c5c3010075adc10002bbce3613c30228993c3a14acf9785ac452b39608fa8cb7e9f810490710b91be4558c9a30342e679a44e7ba88fe060eb563da7369e2bba
diff --git a/app-portage/elicense/elicense-1.0.0.ebuild b/app-portage/elicense/elicense-1.0.0.ebuild
new file mode 100644
index 000000000000..a7cb3da3c328
--- /dev/null
+++ b/app-portage/elicense/elicense-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/Whissi/elicense.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Whissi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="Tool to find installed packages in Gentoo with non-accepted license(s)"
+HOMEPAGE="https://github.com/Whissi/elicense"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
diff --git a/app-portage/elicense/elicense-9999.ebuild b/app-portage/elicense/elicense-9999.ebuild
new file mode 100644
index 000000000000..a7cb3da3c328
--- /dev/null
+++ b/app-portage/elicense/elicense-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/Whissi/elicense.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Whissi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="Tool to find installed packages in Gentoo with non-accepted license(s)"
+HOMEPAGE="https://github.com/Whissi/elicense"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
diff --git a/app-portage/elicense/metadata.xml b/app-portage/elicense/metadata.xml
new file mode 100644
index 000000000000..a100a0b4e8f7
--- /dev/null
+++ b/app-portage/elicense/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">Whissi/elicense</remote-id>
+ </upstream>
+</pkgmetadata>