summaryrefslogtreecommitdiff
path: root/app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild')
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild
new file mode 100644
index 000000000000..b4d12bac27be
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tool to guess CPU_FLAGS_* flags for the host"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v%-r*} -lt 2 ]]; then
+ elog 'Please note that the output has changed in v2. The new format is suitable'
+ elog 'both for Portage and Paludis. To use it, e.g.:'
+ elog
+ elog ' $ echo "*/* $(cpuid2cpuflags)" > /etc/portage/package.use/00cpuflags'
+ elog
+ elog '(you may need to convert package.use into a directory if you want to use'
+ elog ' separate file as presented here)'
+ fi
+ done
+}