summaryrefslogtreecommitdiff
path: root/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild')
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
new file mode 100644
index 000000000000..cc95afbc6f2f
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit python-r1
+
+MY_PN=cpuinfo2cpuflags
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Script to guess CPU_FLAGS_X86 flags from /proc/cpuinfo"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ python_foreach_impl python_newscript "${MY_PN}-x86"{.py,}
+}
+
+pkg_postinst() {
+ if has_version 'sys-apps/portage' \
+ && ! has_version "sys-apps/portage[${PYTHON_USEDEP}]"
+ then
+ ewarn "Support for matching Python implementations should be enabled"
+ ewarn "on sys-apps/portage as well. Otherwise, cpuinfo2cpuflags won't"
+ ewarn "be able to figure out the correct repository location and will"
+ ewarn "require you to specify it explicitly."
+ fi
+}