summaryrefslogtreecommitdiff
path: root/app-portage/conf-update
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /app-portage/conf-update
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'app-portage/conf-update')
-rw-r--r--app-portage/conf-update/Manifest3
-rw-r--r--app-portage/conf-update/conf-update-1.0.3-r1.ebuild28
-rw-r--r--app-portage/conf-update/files/conf-update-1.0.3-fno-common.patch64
3 files changed, 82 insertions, 13 deletions
diff --git a/app-portage/conf-update/Manifest b/app-portage/conf-update/Manifest
index 5de1aa314173..1ad498ebf9cb 100644
--- a/app-portage/conf-update/Manifest
+++ b/app-portage/conf-update/Manifest
@@ -1,3 +1,4 @@
+AUX conf-update-1.0.3-fno-common.patch 1945 BLAKE2B 9619507d58509bde87d0f436860d69738c5c5e96192926ba64ca9a6f5ccb35f225b3f44808c92e61599728cb602e49001f20a0b947fb6759578855881e4a4826 SHA512 692fce54d499c9d561ee5bb959a292117d25b60ab9a315e1c36d6a2472eccdd5b83dec4779283509f80913d53c4f71395a0f0bf0225d516fb01b277812d2e6a4
DIST conf-update-1.0.3.tar.bz2 18296 BLAKE2B 7551b8de644bacf00764c8ad989cbf0c96be3ca4733a26b5f3083b3a9d26c3b8e1fe3525ccfc648aa9543bbc73ff6e3a949c5a3e7d59f71a008f73a720042f4d SHA512 7f20a4974f804d73729105d9abc0f3205a7574c6e2c6dbf020404f3161500b5ecc60d141e0833e9ae0f43a814591a74cd885a5033f50864bbcfb36ba452175b7
-EBUILD conf-update-1.0.3-r1.ebuild 885 BLAKE2B 37bfcec5276375d4a179dfa7264051192c0efe5fb0762329dee82ef8b219b2fcaebf151dc1a6d4667b9f18327ebec46aaf10f9147e92d69267b4f85059e0ff71 SHA512 9f1983417e066bd533ccceb808c42b08e3e89a5995aae0f41f066f51eb1b1621b41e771c28429bcc8a5e15853d8d06d54f7c145fbffe74f47ac432639117f667
+EBUILD conf-update-1.0.3-r1.ebuild 905 BLAKE2B 927274f70f52809a0098b25c86cb38c673b317c6e89e53487f6dca60b055972f258939f811ccd56ebd66bcd54f297419d15d97a91c3c7e22f5ac1edee18ddc42 SHA512 0b1221fd49ddd29b7986624e86f910bea7ed6c99ccdb894c4996321221890d38e8960987e3e3f042aa211af96cba1849c3690c8a1f0f401de9d5e6ddd3411351
MISC metadata.xml 389 BLAKE2B 201f0324021e977b97d3599ad5402d6294f1f798a05bf61bc82b3ed706a4112eaba2b7a41949b04da598909970625522e4ceb9d78e9dd140644f2f390c2873e8 SHA512 83867504b2d791a0eda45a700af3e9df0d878c8dca9622e3bc7809bc7fdc2f80fe5c4812caed1820e90d3521dfeb3aee8baf83cbfac3daa6d3ede3b25904d9c2
diff --git a/app-portage/conf-update/conf-update-1.0.3-r1.ebuild b/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
index b599d25db4be..e45068f6d28a 100644
--- a/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
+++ b/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="${PN} is a ncurses-based config management utility"
HOMEPAGE="https://gitweb.gentoo.org/proj/conf-update.git/"
@@ -14,18 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="colordiff libressl"
-RDEPEND=">=dev-libs/glib-2.6
- sys-libs/ncurses:0
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- colordiff? ( app-misc/colordiff )"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
+RDEPEND="
+ dev-libs/glib
+ sys-libs/ncurses:0
+ colordiff? ( app-misc/colordiff )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
- sed -i -e "s/\$Rev:.*\\$/${PVR}/" "${S}"/"${PN}".h || die
+ default
+ sed -i -e "s/\$Rev:.*\\$/${PVR}/" ${PN}.h || die
if use colordiff ; then
- sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf \ die 'colordiff-sed failed'
+ sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf || die
fi
tc-export PKG_CONFIG
}
diff --git a/app-portage/conf-update/files/conf-update-1.0.3-fno-common.patch b/app-portage/conf-update/files/conf-update-1.0.3-fno-common.patch
new file mode 100644
index 000000000000..04c72687dde5
--- /dev/null
+++ b/app-portage/conf-update/files/conf-update-1.0.3-fno-common.patch
@@ -0,0 +1,64 @@
+--- a/config.c
++++ b/config.c
+@@ -1,5 +1,7 @@
+ #include "conf-update.h"
+
++struct configuration config;
++
+ bool get_boolean(GKeyFile *conffile, const char *key, bool default_value) {
+ GError *error = NULL;
+ bool value, invalid_value, key_not_found;
+@@ -26,7 +28,6 @@ char *get_string(GKeyFile *conffile, const char *key, char *default_value) {
+ }
+
+ void read_config() {
+- extern struct configuration config;
+ GKeyFile *conffile;
+
+ // set reasonable defaults
+--- a/config.h
++++ b/config.h
+@@ -8,6 +8,8 @@ struct configuration {
+ char *diff_tool;
+ char *merge_tool;
+ char *edit_tool;
+-} config;
++};
++
++extern struct configuration config;
+
+ void read_config();
+--- a/core.c
++++ b/core.c
+@@ -1,5 +1,7 @@
+ #include "conf-update.h"
+
++extern struct configuration config;
++
+ char *get_real_filename(const char *update) {
+ char *file = (char *)calloc(strlen(update) + 1 - strlen("._cfg????_"), sizeof(char));
+ strncpy(file, update, strrchr(update, '/') - update + 1);
+@@ -73,7 +75,6 @@ void merge(char *update, char **index) {
+ }
+
+ int show_diff(char *update) {
+- extern struct configuration config;
+ char *realfile = get_real_filename(update);
+ char *esc_realfile = g_shell_quote(realfile);
+ char *esc_update = g_shell_quote(update);
+@@ -98,7 +99,6 @@ int show_diff(char *update) {
+ }
+
+ int edit_update(char *update) {
+- extern struct configuration config;
+ char *esc_update = g_shell_quote(update);
+ char *cmd = calloc(strlen(config.edit_tool) + strlen(" ") + strlen(esc_update), sizeof(char));
+ int ret;
+@@ -116,7 +116,6 @@ int edit_update(char *update) {
+ char **merge_interactively(char *update, char **index) {
+ // customized versions are ._cfg????- with a minus instead of a underscore
+ // that way get_real_filename() works without modification
+- extern struct configuration config;
+ char *realfile = get_real_filename(update);
+ char *esc_realfile = g_shell_quote(realfile);
+ char *esc_update = g_shell_quote(update);