summaryrefslogtreecommitdiff
path: root/app-portage/cfg-update
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /app-portage/cfg-update
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'app-portage/cfg-update')
-rw-r--r--app-portage/cfg-update/Manifest3
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild102
-rw-r--r--app-portage/cfg-update/metadata.xml1
3 files changed, 105 insertions, 1 deletions
diff --git a/app-portage/cfg-update/Manifest b/app-portage/cfg-update/Manifest
index 8b50bbb4784a..39fea8373035 100644
--- a/app-portage/cfg-update/Manifest
+++ b/app-portage/cfg-update/Manifest
@@ -1,3 +1,4 @@
DIST cfg-update-1.8.9.tgz 162356 BLAKE2B 2194b485ae17ee09fe212fb88fee0d3974bb7877b9bee6a243475f689e033e950d9d331108f9360a5bb65b40f2a83916fc9bd208b153d4eb2a6fac0bfb3f4c64 SHA512 2c2d4d5cddaf1c5c8233bfde29b488d682e723da3e267756e203b4ea3c97f2f88615530002975ff07fb466eebed603e4ce227591a1b1e09ef3aca8c2eb17fcb9
+EBUILD cfg-update-1.8.9-r1.ebuild 2973 BLAKE2B 6672d21199b7da09f2ca8e36c2bf7096821c0b8248502b7f8eccfda6a97b3d77e2d87cc3640c92f790206908273273f936bcfe595dc33f7f348be4d0cf7d5666 SHA512 33b319537c10306bf7e42e91a6d7ae7933eaf39efdfda98329f5535add98fac522c7f966052b2d2a58b9a9f810a7da77a97b51ed547742d3e15745da28237e5e
EBUILD cfg-update-1.8.9.ebuild 2979 BLAKE2B 4adf5840f2ee36aab0a60123c735366666a9406268baeed48d8c20f16e97028974d12578475bbe3cb5427bafa277d445028b4541dad6b69a84a0e04385fbef7c SHA512 89543556fa464f6d79d93fb435cf96126d6ac1d2d9a87780b481cd2bf2a497c54d2031198a348d4f184c0a8d8a5a20af99929f7e857b037096a4dc9a8f73e916
-MISC metadata.xml 306 BLAKE2B 3d240b433beed35adcf2d09eddd592c89fe38d5ec4ba4cf9512797d268688a64952d625333a3edcd4b83fa758805322f1b7887f62e8eb8ba19786db27f0106af SHA512 9fa8a2f23fae26309edee6932a754fa8c8bec9446b615ab67e53595eecf8d1ccd1bf8c2f2980f1964105d34727fbdd9c31ccc1494fb8ea430636542470e3c20d
+MISC metadata.xml 331 BLAKE2B dfc62ba6ae96f87c8293d99204ded02444ba1517e4bb189e62459388ac067ef754bccf8e8e9bbec9643614dbeafca3e0deebded689b2f65d590bc32d614cf5d8 SHA512 1c3e7adf10d5482ed3126db2d6c4e4c9ce5b4f89305174ebd19d391b5027c8680a2051677444f4d5fe09d6b03111ea3dc61e036590e0771137ccd8b9c32a2924
diff --git a/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild b/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild
new file mode 100644
index 000000000000..0fae01aee1f3
--- /dev/null
+++ b/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Easy to use GUI & CLI alternative for etc-update"
+HOMEPAGE="https://github.com/rich0/cfg-update"
+SRC_URI="https://github.com/rich0/cfg-update/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="X"
+
+RDEPEND="
+ dev-perl/TermReadKey
+ X? (
+ >=x11-misc/sux-1.0
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/rich0-cfg-update-2f10786"
+
+pkg_prerm() {
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Disabling portage hook"
+ cfg-update --ebuild --disable-portage-hook
+ eend $?
+ ebegin "Disabling paludis hook"
+ cfg-update --ebuild --disable-paludis-hook
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ echo
+ ewarn "If you want to permanently remove cfg-update from your system"
+ ewarn "you should remove the index file /var/lib/cfg-update/checksum.index"
+ echo
+}
+
+src_install() {
+ dobin \
+ cfg-update emerge_with_indexing_for_cfg-update \
+ emerge_with_indexing_for_cfg-update_phphelper \
+ cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
+ insinto /usr/lib/cfg-update
+ doins cfg-update cfg-update_indexing test.tgz
+ dodoc ChangeLog
+ doman *.8
+ insinto /etc
+ doins cfg-update.conf cfg-update.hosts
+ keepdir /var/lib/cfg-update
+}
+
+pkg_postinst() {
+ if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
+ && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
+ then
+ ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
+ mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
+ "${ROOT}"/var/lib/cfg-update/checksum.index
+ eend $?
+ fi
+
+ if [[ -e "${ROOT}"/usr/bin/paludis ]]
+ then
+ echo
+ ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
+ ewarn "that you have some corrupted CONTENTS files on your system..."
+ echo
+ ewarn "Please run: cfg-update --check-packages"
+ echo
+ ewarn "The above command will check all packages installed with Paludis and"
+ ewarn "will output a list of packages that need to be re-installed with"
+ ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
+ ewarn "you risk losing your custom settings when updating configuration"
+ ewarn "files, that belong to these packages, with cfg-update!"
+ echo
+ fi
+
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Moving backups to /var/lib/cfg-update/backups"
+ /usr/bin/cfg-update --ebuild --move-backups
+ eend $?
+ fi
+
+ echo
+ einfo "If this is a first time install, please check the configuration"
+ einfo "in /etc/cfg-update.conf before using cfg-update:"
+ echo
+ einfo "If your system does not have an X-server installed you need to"
+ einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
+ einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
+ einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
+ echo
+ einfo "TIP: to maximize the chances of future automatic updates, run:"
+ einfo "cfg-update --optimize-backups"
+ echo
+}
diff --git a/app-portage/cfg-update/metadata.xml b/app-portage/cfg-update/metadata.xml
index 7ab5e1a53ddd..7e1aa3ceff28 100644
--- a/app-portage/cfg-update/metadata.xml
+++ b/app-portage/cfg-update/metadata.xml
@@ -7,4 +7,5 @@
<upstream>
<remote-id type="github">rich0/cfg-update</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>