summaryrefslogtreecommitdiff
path: root/app-portage/cfg-update
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/cfg-update
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/cfg-update')
-rw-r--r--app-portage/cfg-update/Manifest3
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.9.ebuild104
-rw-r--r--app-portage/cfg-update/metadata.xml10
3 files changed, 117 insertions, 0 deletions
diff --git a/app-portage/cfg-update/Manifest b/app-portage/cfg-update/Manifest
new file mode 100644
index 000000000000..71fe74cbb241
--- /dev/null
+++ b/app-portage/cfg-update/Manifest
@@ -0,0 +1,3 @@
+DIST cfg-update-1.8.9.tgz 162356 BLAKE2B 2194b485ae17ee09fe212fb88fee0d3974bb7877b9bee6a243475f689e033e950d9d331108f9360a5bb65b40f2a83916fc9bd208b153d4eb2a6fac0bfb3f4c64 SHA512 2c2d4d5cddaf1c5c8233bfde29b488d682e723da3e267756e203b4ea3c97f2f88615530002975ff07fb466eebed603e4ce227591a1b1e09ef3aca8c2eb17fcb9
+EBUILD cfg-update-1.8.9.ebuild 2975 BLAKE2B 40ac869ca667a8090a58a873ee46004ff6eff0aa2743233c4a58940ff71779320f3452da0f1a6df3272b9d19172b336ce7c1f712aeb66e52414dcaffa5ecdd15 SHA512 163b354dcdc84e8747a1b93b44adb650ae183cbe19a160972e3ce45069d3757c0b3c0699a9f344fecaedf65c76d05fbb6e5f041dc679f8f8f9b018829f43fbd0
+MISC metadata.xml 305 BLAKE2B 7ee3e6df88046614c6b02661384885e8f61eb72b26555456e5fcb5c034777ad37567c5bc091337cc4aa5f36415bc00ec4b9edd9fbb78cf87f449af966158adb4 SHA512 e0e51a2923f24cb77e5a9dddcdb89b2c4301d3c1b34f6a71be1611890e91ecf8e890852307964594c3c09486aee1e6758ad6d59e902842dd9cb63c6168b6d515
diff --git a/app-portage/cfg-update/cfg-update-1.8.9.ebuild b/app-portage/cfg-update/cfg-update-1.8.9.ebuild
new file mode 100644
index 000000000000..66b2498efec6
--- /dev/null
+++ b/app-portage/cfg-update/cfg-update-1.8.9.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Easy to use GUI & CLI alternative for etc-update"
+HOMEPAGE="https://github.com/rich0/cfg-update"
+SRC_URI="https://github.com/rich0/cfg-update/tarball/${PV} -> ${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="X"
+
+RDEPEND="
+ dev-perl/TermReadKey
+ X? (
+ >=x11-misc/sux-1.0
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/rich0-cfg-update-2f10786"
+
+pkg_prerm() {
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Disabling portage hook"
+ cfg-update --ebuild --disable-portage-hook
+ eend $?
+ ebegin "Disabling paludis hook"
+ cfg-update --ebuild --disable-paludis-hook
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ echo
+ ewarn "If you want to permanently remove cfg-update from your system"
+ ewarn "you should remove the index file /var/lib/cfg-update/checksum.index"
+ echo
+}
+
+src_install() {
+ dobin \
+ cfg-update emerge_with_indexing_for_cfg-update \
+ emerge_with_indexing_for_cfg-update_phphelper \
+ cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
+ insinto /usr/lib/cfg-update
+ doins cfg-update cfg-update_indexing test.tgz
+ dodoc ChangeLog
+ doman *.8
+ insinto /etc
+ doins cfg-update.conf cfg-update.hosts
+ keepdir /var/lib/cfg-update
+}
+
+pkg_postinst() {
+ if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
+ && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
+ then
+ ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
+ mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
+ "${ROOT}"/var/lib/cfg-update/checksum.index
+ eend $?
+ fi
+
+ if [[ -e "${ROOT}"/usr/bin/paludis ]]
+ then
+ echo
+ ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
+ ewarn "that you have some corrupted CONTENTS files on your system..."
+ echo
+ ewarn "Please run: cfg-update --check-packages"
+ echo
+ ewarn "The above command will check all packages installed with Paludis and"
+ ewarn "will output a list of packages that need to be re-installed with"
+ ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
+ ewarn "you risk losing your custom settings when updating configuration"
+ ewarn "files, that belong to these packages, with cfg-update!"
+ echo
+ fi
+
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Moving backups to /var/lib/cfg-update/backups"
+ /usr/bin/cfg-update --ebuild --move-backups
+ eend $?
+ fi
+
+ echo
+ einfo "If this is a first time install, please check the configuration"
+ einfo "in /etc/cfg-update.conf before using cfg-update:"
+ echo
+ einfo "If your system does not have an X-server installed you need to"
+ einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
+ einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
+ einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
+ echo
+ einfo "TIP: to maximize the chances of future automatic updates, run:"
+ einfo "cfg-update --optimize-backups"
+ echo
+}
diff --git a/app-portage/cfg-update/metadata.xml b/app-portage/cfg-update/metadata.xml
new file mode 100644
index 000000000000..1864b4eb4ebf
--- /dev/null
+++ b/app-portage/cfg-update/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rich0/cfg-update</remote-id>
+ </upstream>
+</pkgmetadata>