summaryrefslogtreecommitdiff
path: root/app-portage/cfg-update
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/cfg-update
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/cfg-update')
-rw-r--r--app-portage/cfg-update/Manifest5
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.9.ebuild104
-rw-r--r--app-portage/cfg-update/metadata.xml10
3 files changed, 119 insertions, 0 deletions
diff --git a/app-portage/cfg-update/Manifest b/app-portage/cfg-update/Manifest
new file mode 100644
index 000000000000..947257e349e8
--- /dev/null
+++ b/app-portage/cfg-update/Manifest
@@ -0,0 +1,5 @@
+DIST cfg-update-1.8.9.tgz 162356 SHA256 82d14b3cd7b1c144d7d77836919689471cd31c69cefba9b8714580e6cf1e495e SHA512 2c2d4d5cddaf1c5c8233bfde29b488d682e723da3e267756e203b4ea3c97f2f88615530002975ff07fb466eebed603e4ce227591a1b1e09ef3aca8c2eb17fcb9 WHIRLPOOL d17b179bc4589cc650178e981c0d5a6e336023f3128a9b76c1a4a19e0fe347982ff75d2337ed972e040fec1b93097b4336818b748f2af20eccb2e82f332417af
+EBUILD cfg-update-1.8.9.ebuild 2975 SHA256 dc1071e12b479f82b666466f9197a5425632b00d9cb2bb4a31eb84c93dd1a6cf SHA512 163b354dcdc84e8747a1b93b44adb650ae183cbe19a160972e3ce45069d3757c0b3c0699a9f344fecaedf65c76d05fbb6e5f041dc679f8f8f9b018829f43fbd0 WHIRLPOOL 4aa0d3c57d2f2e5d081436038addafa5552c9840f3481572b1730ecbe2c35e33143801288c1b16d0800a6f1612ad21eec86a8e6590222b75532afb4abc9ad040
+MISC ChangeLog 2558 SHA256 3458130d6df999a11519df02596e738cd986ac707c8e2a76d8fea8a4dc497e1d SHA512 969a676661d5747ed8593ccb9ac43dfd7a8b746cc39f1c3be743acd58f7fdbff08ff627c4d45d0d7eca762da96347b6c174fa706b12fbd4a042f75f1bc78f10f WHIRLPOOL e0a932649db9456c670d0411905b85598d861b37c66f7969ab6becad2d49796a0d425ad958ddfe9e955d3d3aeb9d09ab636f9139bd65e731c3c1ba4f7b1500d4
+MISC ChangeLog-2015 6406 SHA256 d4568900cd9c096c6b9463c0e5206c461d9c2c204d49e0d025cf1e0309d3d86c SHA512 cebb82206c159d33eb7c1a1061337d5921c01dce61996ecb3f01dc2390b4c53f6b8203055c9770f501978a8091817b8a0b5d160b11c9c3c4314077c8bbeef38c WHIRLPOOL 82c24398587288bdcbed2871a3b684798686864a512c716cf995861e22195afeb20aba79c43ff8873ffb2df80d9750c8237a4d6e941b5e063cd2417efc44b039
+MISC metadata.xml 305 SHA256 74328f3fc93cfd1234e8bd0baf5ea2047073a5d1a8880385fe2be626cdefa740 SHA512 e0e51a2923f24cb77e5a9dddcdb89b2c4301d3c1b34f6a71be1611890e91ecf8e890852307964594c3c09486aee1e6758ad6d59e902842dd9cb63c6168b6d515 WHIRLPOOL 15ebfcf86b60350ee1e17598875c3eee33fdacffd3e7cac290a06fe7f7d003248bc20539b815b14b7d7ae046ca7ac2e35d9135696e21750c97e8f9fcdaf63349
diff --git a/app-portage/cfg-update/cfg-update-1.8.9.ebuild b/app-portage/cfg-update/cfg-update-1.8.9.ebuild
new file mode 100644
index 000000000000..66b2498efec6
--- /dev/null
+++ b/app-portage/cfg-update/cfg-update-1.8.9.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Easy to use GUI & CLI alternative for etc-update"
+HOMEPAGE="https://github.com/rich0/cfg-update"
+SRC_URI="https://github.com/rich0/cfg-update/tarball/${PV} -> ${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="X"
+
+RDEPEND="
+ dev-perl/TermReadKey
+ X? (
+ >=x11-misc/sux-1.0
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/rich0-cfg-update-2f10786"
+
+pkg_prerm() {
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Disabling portage hook"
+ cfg-update --ebuild --disable-portage-hook
+ eend $?
+ ebegin "Disabling paludis hook"
+ cfg-update --ebuild --disable-paludis-hook
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ echo
+ ewarn "If you want to permanently remove cfg-update from your system"
+ ewarn "you should remove the index file /var/lib/cfg-update/checksum.index"
+ echo
+}
+
+src_install() {
+ dobin \
+ cfg-update emerge_with_indexing_for_cfg-update \
+ emerge_with_indexing_for_cfg-update_phphelper \
+ cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
+ insinto /usr/lib/cfg-update
+ doins cfg-update cfg-update_indexing test.tgz
+ dodoc ChangeLog
+ doman *.8
+ insinto /etc
+ doins cfg-update.conf cfg-update.hosts
+ keepdir /var/lib/cfg-update
+}
+
+pkg_postinst() {
+ if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
+ && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
+ then
+ ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
+ mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
+ "${ROOT}"/var/lib/cfg-update/checksum.index
+ eend $?
+ fi
+
+ if [[ -e "${ROOT}"/usr/bin/paludis ]]
+ then
+ echo
+ ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
+ ewarn "that you have some corrupted CONTENTS files on your system..."
+ echo
+ ewarn "Please run: cfg-update --check-packages"
+ echo
+ ewarn "The above command will check all packages installed with Paludis and"
+ ewarn "will output a list of packages that need to be re-installed with"
+ ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
+ ewarn "you risk losing your custom settings when updating configuration"
+ ewarn "files, that belong to these packages, with cfg-update!"
+ echo
+ fi
+
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Moving backups to /var/lib/cfg-update/backups"
+ /usr/bin/cfg-update --ebuild --move-backups
+ eend $?
+ fi
+
+ echo
+ einfo "If this is a first time install, please check the configuration"
+ einfo "in /etc/cfg-update.conf before using cfg-update:"
+ echo
+ einfo "If your system does not have an X-server installed you need to"
+ einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
+ einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
+ einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
+ echo
+ einfo "TIP: to maximize the chances of future automatic updates, run:"
+ einfo "cfg-update --optimize-backups"
+ echo
+}
diff --git a/app-portage/cfg-update/metadata.xml b/app-portage/cfg-update/metadata.xml
new file mode 100644
index 000000000000..1864b4eb4ebf
--- /dev/null
+++ b/app-portage/cfg-update/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rich0/cfg-update</remote-id>
+ </upstream>
+</pkgmetadata>