summaryrefslogtreecommitdiff
path: root/app-pda/usbmuxd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-pda/usbmuxd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-pda/usbmuxd')
-rw-r--r--app-pda/usbmuxd/Manifest3
-rw-r--r--app-pda/usbmuxd/metadata.xml5
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild33
3 files changed, 41 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/Manifest b/app-pda/usbmuxd/Manifest
new file mode 100644
index 000000000000..db0048ba8088
--- /dev/null
+++ b/app-pda/usbmuxd/Manifest
@@ -0,0 +1,3 @@
+DIST usbmuxd-1.0.8_p20140530.tar.xz 46988 BLAKE2B 8efedee3231b134995316fc295fffd975271aa9d630aa6e3d96ccda472634422299aadb92acda09b6802cdcf9e99af0c165dcbed153d0a5027ffcc8f26126cdc SHA512 200c9bd208ef9e8d5e0a9b2779ff260efe6319333ce27c93a0686ba924e6cfaa1a003072c3eabbe46d495a66bc47c3cd6e82482653fde5e1a7ae0edd9b838fac
+EBUILD usbmuxd-1.0.8_p20140530.ebuild 869 BLAKE2B 0e2e9847b97a06661acff0aa19d8518fa73361211d8e89758ab18c090f6917c412ecf8ad4e00b917dca5ecbce2a82293f52a38b38915fbbe863eb5596261ce83 SHA512 5ac79095dff7495464783e39ad99e15817e72f96c8bad9ee77fa904f21b3bddc5419f708f6639d7026889a282463347bf3ed80d8226b095e28e70a451acdbbf0
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-pda/usbmuxd/metadata.xml b/app-pda/usbmuxd/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-pda/usbmuxd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild
new file mode 100644
index 000000000000..f4c8c46ae9c1
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils udev user
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+#SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.6
+ >=app-pda/libplist-1.11
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup plugdev
+ enewuser usbmux -1 -1 -1 "usb,plugdev"
+}
+
+src_install() {
+ autotools-utils_src_install udevrulesdir="$(get_udevdir)"/rules.d
+}