summaryrefslogtreecommitdiff
path: root/app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild')
-rw-r--r--app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild b/app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..7692c22ec8a0
--- /dev/null
+++ b/app-pda/libusbmuxd/libusbmuxd-2.0.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://www.libimobiledevice.org/"
+SRC_URI="https://cgit.libimobiledevice.org/${PN}.git/snapshot/${P}.tar.bz2"
+LICENSE="GPL-2+ LGPL-2.1+" # tools/*.c is GPL-2+, rest is LGPL-2.1+
+SLOT="0/2.0-6" # based on SONAME of libusbmuxd-2.0.so
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=app-pda/libplist-2.2.0:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(usex kernel_linux '' --without-inotify)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}