summaryrefslogtreecommitdiff
path: root/app-pda/libplist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-pda/libplist
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-pda/libplist')
-rw-r--r--app-pda/libplist/Manifest4
-rw-r--r--app-pda/libplist/libplist-2.0.0.ebuild3
-rw-r--r--app-pda/libplist/libplist-2.1.0.ebuild98
3 files changed, 103 insertions, 2 deletions
diff --git a/app-pda/libplist/Manifest b/app-pda/libplist/Manifest
index 1f4edddc48e8..6eeb702ec42a 100644
--- a/app-pda/libplist/Manifest
+++ b/app-pda/libplist/Manifest
@@ -1,3 +1,5 @@
DIST libplist-2.0.0.tar.bz2 421405 BLAKE2B 2f6e22c871ad3b5ace2a2c6aab09706e8a8c1759f1656c5c07164e5b89a1b5eae24d2d7472e0dcca7eddd96b641715acfe5a0a791b0b994ec5fbcdf70627acf9 SHA512 81508bf6773483528816725c3b5b868563b84fd7810999404072e5ea9efa7fc9f11ef997f32208e4421aa26b15edd0c65f87c67c1472e8c4e356f1e9fe7740ee
-EBUILD libplist-2.0.0.ebuild 2049 BLAKE2B 9b7ce1a5188a3982c686a835ce270e3a1d65059ed33e375b7707737aa44d524ad3456ff8799b503c65e5a6576a824ade3a7bf7bed6a058b5aaca5e3928714384 SHA512 ab99c65b6fbcce81161754bbc8fad8ea42956a019785ddb0d771b98fefed5621827ef0dd0cc7cd91f5915cf93ce00eb84116f4b8c836aa5ac60bf9cca5cbb709
+DIST libplist-2.1.0.tar.bz2 120602 BLAKE2B 8abfe3c295c4ebd242f2c4d49c80d1f214097df84f1d2fcf2696519bbbca4e8a5ce13c04690ac64fd981f84d585df25fc65c268a4e4f4092319053583e67736c SHA512 23156e882835bb0b894a05b57018b5e76f9f8f8f4b1d3fdad7b1970d2ef695033c98de74a1fa81bdf0829742a058fd65075cebc1512313d2be42e2f5367274be
+EBUILD libplist-2.0.0.ebuild 2060 BLAKE2B 2c23e030b23ff17563e93df3231ca4ac7cbbd988462b3743f3e3c2bb90156bf888a17be48342eab8acabd87daa0185105acbf996a192f032bcb52ef027313ad0 SHA512 14455c770264ca2d42dbfdc588eea8c2abea209515fc9b92638dfec73e9f35dab1bc2cadd2d95aa97dc1be9e4ba42153ae1b39a27286f5c324d03f4643b53b5b
+EBUILD libplist-2.1.0.ebuild 2148 BLAKE2B af693d4f5a8460831e6f3073bbce9eef64ba538db75317b18f22e76874a1ede5d291482871f61fb4d2e7d71758b7994c94884604d3ca1988a1f5a8ec819e9417 SHA512 426589b2180cde9692224c4d7889f96c9c709671b101ea11c597ab9e4ac4901a586f330ade250988b49cbb87b2d11a742360d6698b26fe1a682b6f3a9b1ec579
MISC metadata.xml 329 BLAKE2B accbb4a0f223b37358e54635e61f1488abf2148d89e166e4a68e8ddfc90e0d4c3438c52d75c24aeced91c2246e537cb0b1d64e6e9c63425c6392148cbc3bcd58 SHA512 69d57118df488610f977fe8722d463bb858e8329855cf439ae3c1c7c52260dec96505535e9424041d71d000951db199312e382d24f66296c9c408113ead5219d
diff --git a/app-pda/libplist/libplist-2.0.0.ebuild b/app-pda/libplist/libplist-2.0.0.ebuild
index 37e0c7cd5e80..c1aa521a377c 100644
--- a/app-pda/libplist/libplist-2.0.0.ebuild
+++ b/app-pda/libplist/libplist-2.0.0.ebuild
@@ -43,7 +43,8 @@ src_configure() {
}
do_configure_python() {
- PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
+ local -x PYTHON_LDFLAGS="$(python_get_LIBS)"
+ do_configure "$@"
}
do_configure --without-cython
diff --git a/app-pda/libplist/libplist-2.1.0.ebuild b/app-pda/libplist/libplist-2.1.0.ebuild
new file mode 100644
index 000000000000..7b342d04b16d
--- /dev/null
+++ b/app-pda/libplist/libplist-2.1.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit autotools python-r1 toolchain-funcs
+
+DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
+HOMEPAGE="https://www.libimobiledevice.org/"
+SRC_URI="https://cgit.libimobiledevice.org/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="python static-libs"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ python? ( >=dev-python/cython-0.17[${PYTHON_USEDEP}] )
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( AUTHORS NEWS README.md )
+
+BUILD_DIR="${S}_build"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local ECONF_SOURCE=${S}
+ local myeconfargs=( $(use_enable static-libs static) )
+
+ do_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" >/dev/null || die
+ econf "${myeconfargs[@]}" "${@}"
+ popd >/dev/null || die
+ }
+
+ do_configure_python() {
+ local -x PYTHON_LDFLAGS="$(python_get_LIBS)"
+ do_configure "$@"
+ }
+
+ # Don't prefer clang.
+ tc-export CC CXX
+
+ do_configure --without-cython
+ use python && python_foreach_impl do_configure_python
+}
+
+src_compile() {
+ python_compile() {
+ emake -C "${BUILD_DIR}"/cython \
+ VPATH="${S}/cython:${native_builddir}/cython" \
+ plist_la_LIBADD="${native_builddir}/src/libplist.la"
+ }
+
+ local native_builddir=${BUILD_DIR}
+ pushd "${BUILD_DIR}" >/dev/null || die
+ emake
+ use python && python_foreach_impl python_compile
+ popd >/dev/null || die
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" check
+}
+
+src_install() {
+ python_install() {
+ emake -C "${BUILD_DIR}/cython" \
+ VPATH="${S}/cython:${native_builddir}/cython" \
+ DESTDIR="${D}" install
+ }
+
+ local native_builddir=${BUILD_DIR}
+ pushd "${BUILD_DIR}" >/dev/null || die
+ emake DESTDIR="${D}" install
+ use python && python_foreach_impl python_install
+ popd >/dev/null || die
+
+ einstalldocs
+
+ if use python ; then
+ insinto /usr/include/plist/cython
+ doins cython/plist.pxd
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}