summaryrefslogtreecommitdiff
path: root/app-pda/libplist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-pda/libplist
reinit the tree, so we can have metadata
Diffstat (limited to 'app-pda/libplist')
-rw-r--r--app-pda/libplist/Manifest5
-rw-r--r--app-pda/libplist/libplist-2.0.0.ebuild87
-rw-r--r--app-pda/libplist/metadata.xml9
3 files changed, 101 insertions, 0 deletions
diff --git a/app-pda/libplist/Manifest b/app-pda/libplist/Manifest
new file mode 100644
index 000000000000..b5b21961b1ad
--- /dev/null
+++ b/app-pda/libplist/Manifest
@@ -0,0 +1,5 @@
+DIST libplist-2.0.0.tar.bz2 421405 SHA256 3a7e9694c2d9a85174ba1fa92417cfabaea7f6d19631e544948dc7e17e82f602 SHA512 81508bf6773483528816725c3b5b868563b84fd7810999404072e5ea9efa7fc9f11ef997f32208e4421aa26b15edd0c65f87c67c1472e8c4e356f1e9fe7740ee WHIRLPOOL cfea767321dda602722281f189dae708969c7471bc4b9388638b671257f3808358e1227cdf29cba7751cb715a8ec92fccb1c0dd5c8d150ebac19fdf8633c6339
+EBUILD libplist-2.0.0.ebuild 2060 SHA256 ba23fa96c8208cc5e57ae67567398ee3494c7c671e6b22fb7f5e11cf2e2f7fb9 SHA512 25f9d3ef34947a91244e8e7c78aca6b5cc2337c9c60d0949090f50fd46067f1e07413630070639f1f46a96bf4ce0fcaee7554f3983f9dde415b0273042999c5e WHIRLPOOL 34f711c8dda671c68ee7272c0f50802ac1348788619cff82e6a0fedcbe6af12be49bdf484c87180d89eb190745af9f9758fd5cacee37b9a20b4ae028f9b93174
+MISC ChangeLog 4309 SHA256 6900b3cc941d6b0dfa451964ec2bb2072042d82290e965ee2b492d42f7e6d8ed SHA512 be5b742af236adb8d473bd3cbfe0a22c304d7fda88cc98715d8f8e1990cd1b464a60456c3b52f3bc521cd2c026a18176aebd1e0872b80608236127c8baa96451 WHIRLPOOL 9e2a438aa80cce89b0a4a2e7f6b211746b1de195dac0c826333272ed08b2203771e15c89fc8f61046d66d976acb52f8d4832c92f5a6915a1357e2d9b9669d059
+MISC ChangeLog-2015 5691 SHA256 80e7b81e7fe641d1fb4e95c9b7ee8a0211dbaf55a8d0fbaca97fc85d2111425f SHA512 e247b80462e5bb6289f65a1dc55638c9a318d745ab48b70f00525c257480d6e81833c2243c32bab3133950dfbb3b9d3caba81db60c4b7cd971a350148e751ba5 WHIRLPOOL 75c229798ac7b546ed200fddcda0fd549814df4c8bbb66babc603f504c85801a94f4ee97ba37278a39d4b73d7f4e1014c8018fbe12e6f8df9980b15a8e01521d
+MISC metadata.xml 329 SHA256 6ecc0c0900d3b6ca157cf9d9ff3ee5440131af153bf1b874cdbde16032c6181f SHA512 69d57118df488610f977fe8722d463bb858e8329855cf439ae3c1c7c52260dec96505535e9424041d71d000951db199312e382d24f66296c9c408113ead5219d WHIRLPOOL d9905811e665b382f497c4321070cb49532fa3a401b697975078bbea426826aefc60a65156a3139a2193dba286a6f1216c8aa7d2b17d29b6decf6f1377a05d66
diff --git a/app-pda/libplist/libplist-2.0.0.ebuild b/app-pda/libplist/libplist-2.0.0.ebuild
new file mode 100644
index 000000000000..af02a8b43683
--- /dev/null
+++ b/app-pda/libplist/libplist-2.0.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit autotools eutils python-r1
+
+DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/3.1.0" # based on SONAME of libplist.so
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86 ~amd64-fbsd"
+IUSE="python static-libs"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ python? ( >=dev-python/cython-0.17[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( AUTHORS NEWS README )
+
+BUILD_DIR="${S}_build"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local ECONF_SOURCE=${S}
+ local myeconfargs=( $(use_enable static-libs static) )
+
+ do_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" >/dev/null || die
+ econf "${myeconfargs[@]}" "${@}"
+ popd >/dev/null || die
+ }
+
+ do_configure_python() {
+ PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
+ }
+
+ do_configure --without-cython
+ use python && python_foreach_impl do_configure_python
+}
+
+src_compile() {
+ python_compile() {
+ emake -C "${BUILD_DIR}"/cython -j1 \
+ VPATH="${S}/cython:${native_builddir}/cython" \
+ plist_la_LIBADD="${native_builddir}/src/libplist.la"
+ }
+
+ local native_builddir=${BUILD_DIR}
+ pushd "${BUILD_DIR}" >/dev/null || die
+ emake -j1
+ use python && python_foreach_impl python_compile
+ popd >/dev/null || die
+}
+
+src_install() {
+ python_install() {
+ emake -C "${BUILD_DIR}/cython" -j1 \
+ VPATH="${S}/cython:${native_builddir}/cython" \
+ DESTDIR="${D}" install
+ }
+
+ local native_builddir=${BUILD_DIR}
+ pushd "${BUILD_DIR}" >/dev/null || die
+ emake -j1 DESTDIR="${D}" install
+ use python && python_foreach_impl python_install
+ popd >/dev/null || die
+
+ einstalldocs
+
+ if use python ; then
+ insinto /usr/include/plist/cython
+ doins cython/plist.pxd
+ fi
+ prune_libtool_files --all
+}
diff --git a/app-pda/libplist/metadata.xml b/app-pda/libplist/metadata.xml
new file mode 100644
index 000000000000..7cae0531e52c
--- /dev/null
+++ b/app-pda/libplist/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+ <upstream>
+ <bugs-to>https://github.com/libimobiledevice/libplist/issues</bugs-to>
+ <remote-id type="github">libimobiledevice/libplist</remote-id>
+ </upstream>
+</pkgmetadata>