summaryrefslogtreecommitdiff
path: root/app-pda/iripdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-pda/iripdb
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-pda/iripdb')
-rw-r--r--app-pda/iripdb/Manifest3
-rw-r--r--app-pda/iripdb/iripdb-0.1.3b.ebuild38
-rw-r--r--app-pda/iripdb/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/app-pda/iripdb/Manifest b/app-pda/iripdb/Manifest
new file mode 100644
index 000000000000..5b9e49c59c6a
--- /dev/null
+++ b/app-pda/iripdb/Manifest
@@ -0,0 +1,3 @@
+DIST iRipDB-0.1.3b.zip 32000 BLAKE2B 139affccb8545756c0d0e2652b7b1851b588aad3fcbcad04a88ccb517bcb10bd7aa4d46bc87885a6b32b0d27564bb98cde2bf21846140eb572f9c1953dba4d8a SHA512 7d3811e12a8570a07d2381bf6e97c9818b0da5b38dca95fc66441635343d827395d16fcdc7cea49179c062888ecbd88722f379ed59664919e10050618e66e8d5
+EBUILD iripdb-0.1.3b.ebuild 892 BLAKE2B 80c4dabb4da82e6f3f3f9fd6061b4307ed2024c4ddf235df28c4f87b5fa29f251c0d2c9ec7af7ee53b4ada6890e58c15f03d600b992779667c4bc1eb8a72c685 SHA512 c671f4b4c66841f38605147a82c980b467df3267ea2f298a8200eb4ba68edc1878e69a74dfdc7a88d351a6e8d7cea9246b19365fc471298bfdc56d419a4e9097
+MISC metadata.xml 579 BLAKE2B 264497ce16f001b7fb8c86880829d553ca82bdea0e6f6d41910b850369471dac9b41c9d8e937ff5abe278f1e1758d2541e0814db8937da195ebddb837ac3efa6 SHA512 b3c40a10ecbb9a7d700b37172c9ce5917554a89a5e3d0c88f1b7032f08b7187f0cb09bcb91288330715d3d4f19078ec639e3e56ac1f33c334ec16dc59a59e011
diff --git a/app-pda/iripdb/iripdb-0.1.3b.ebuild b/app-pda/iripdb/iripdb-0.1.3b.ebuild
new file mode 100644
index 000000000000..959d4997dc63
--- /dev/null
+++ b/app-pda/iripdb/iripdb-0.1.3b.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+MY_P="${P/iripdb/iRipDB}"
+
+DESCRIPTION="Allows generating the DB files necessary for the iRiver iHP-1xx"
+HOMEPAGE="http://www.fataltourist.com/iripdb/"
+SRC_URI="http://www.fataltourist.com/iripdb/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/taglib
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ echo "$(tc-getCXX) ${CXXFLAGS} -c -o main.o main.cpp"
+ $(tc-getCXX) ${CXXFLAGS} -c -o main.o -I/usr/include/taglib main.cpp
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++
+}
+
+src_install() {
+ dobin iripdb
+ dodoc AUTHORS README doc/iRivDB_structure
+}
diff --git a/app-pda/iripdb/metadata.xml b/app-pda/iripdb/metadata.xml
new file mode 100644
index 000000000000..039a8621d5cc
--- /dev/null
+++ b/app-pda/iripdb/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ iRipDB allows generating the DB files necessary for the iRiver iHP-1xx
+ series of MP3/Ogg HD Player on Linux and Windows. That will allow you
+ to navigate your files through the artist/album/genre menus. It supports
+ adding MP3 and Ogg files at this point. It's released under the GNU's
+ General Public License and, at this moment only in source code form.
+ </longdescription>
+</pkgmetadata>