summaryrefslogtreecommitdiff
path: root/app-pda/ifuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 02:57:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 02:57:39 +0100
commit24162508832f37f873ab12dfdfb191cf99318055 (patch)
tree3f9d1bac9025c4a823e0d7f948110aa74857baf8 /app-pda/ifuse
parent26262b314fa723a2e86f4a9b8b344a72eb9c0393 (diff)
gentoo auto-resync : 26:07:2022 - 02:57:39
Diffstat (limited to 'app-pda/ifuse')
-rw-r--r--app-pda/ifuse/Manifest4
-rw-r--r--app-pda/ifuse/ifuse-1.1.4.ebuild39
-rw-r--r--app-pda/ifuse/metadata.xml5
3 files changed, 46 insertions, 2 deletions
diff --git a/app-pda/ifuse/Manifest b/app-pda/ifuse/Manifest
index e4993534360e..71b58203b67a 100644
--- a/app-pda/ifuse/Manifest
+++ b/app-pda/ifuse/Manifest
@@ -1,3 +1,5 @@
DIST ifuse-1.1.3.tar.bz2 90803 BLAKE2B fd47f2e73d11e8f7c26f5684f4287ba51a8c65b0d6e0ff058bdd0290810ab9de671a2a61a089713e7560506f607d47692d882c7e49d8d3d154f9cf7940e5e153 SHA512 bacf0b00ebc7681022f6e85daa005ee19c99f3222e5db5c4ea6630c2c46111dd3ccd7efcfdbcfabf06cc18ceb58b054c1adb2d106d9b3b7d60a12f3b79c64a3c
+DIST ifuse-1.1.4.tar.bz2 94137 BLAKE2B 0abe1a2324820380faf5868f59a45c11aab8991ff8529bd6f64a279b046da88a9cd35b352cd89b4a64d36f35c56b46efab5138f3b72ec8886103ffaaeeff50f1 SHA512 671fabb0828fb6dd5ddba80ef418005305f4ee4676ab1078513a83582e84616f47c8973c25e1fdd8897b08a01a135080898a55d3ad8b31e89c0bb72ee865cdff
EBUILD ifuse-1.1.3-r1.ebuild 894 BLAKE2B a6633a4d83b6f856940252ff65352d134f68a8f44c6b2a3d4d22b77e74261a9fbae9c9532f68d52310952fde2d7032add3b9004a06d3ce2cc16116a47c0a9285 SHA512 e41469aeaae2509e224c28e47d81a6810398561454834eb9c94c88114d72a9459d5af0c2d5463f80d852fd8504d8f33fed8f20352321b3654d2fbf6ca5e686a8
-MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
+EBUILD ifuse-1.1.4.ebuild 987 BLAKE2B 16bfafd59b0239dba4db31404a4d16492963e899f8d869390af0d26bb0909bd1d00d8908d761c9693886328c515145b8eac96b733857132edf6c50dfe5f7ce88 SHA512 4c3ac74d3b99872d937fc8968cbea37c061c3d8142ecf26ba3d10842980678162ceb27f8d38e5dd1651dd560c700ab3b94f9043ef6086e5f24953f2c14047bcb
+MISC metadata.xml 248 BLAKE2B 2a8d109f789d4f561986cfd5830c49c96b715e2fd50c0340e5c7ca385f72d09c0accf9102e1e1338e971400861d3baa95c083623231cbe96dc9e8163639dee25 SHA512 46a1388868fb5dcf5e3f85cbe8438d441c8a1ff291fcceb1cb4cf20a505e84e945c73967342eb7faadbaa51a7630977d9d447fe16505395fe7a05024e6242185
diff --git a/app-pda/ifuse/ifuse-1.1.4.ebuild b/app-pda/ifuse/ifuse-1.1.4.ebuild
new file mode 100644
index 000000000000..5e92a5c73c47
--- /dev/null
+++ b/app-pda/ifuse/ifuse-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="https://www.libimobiledevice.org/ https://github.com/libimobiledevice/ifuse/"
+SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-pda/libimobiledevice-1.3.0:=
+ >=app-pda/libplist-2.2:=
+ sys-fs/fuse:0
+"
+RDEPEND="
+ ${DEPEND}
+ app-pda/usbmuxd
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Only use this filesystem driver to create backups of your data.
+The music database is hashed, and attempting to add files will cause the
+iPod/iPhone to consider your database unauthorised.
+It will respond by wiping all media files, requiring a restore through iTunes."
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-pda/ifuse/metadata.xml b/app-pda/ifuse/metadata.xml
index 85e4ed814fa2..e91ef31902f9 100644
--- a/app-pda/ifuse/metadata.xml
+++ b/app-pda/ifuse/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+ </maintainer>
</pkgmetadata>